Keyboard shortcuts

The official TeXShop Support Forum.

Keyboard shortcuts

Postby Leuwen » Sat Nov 13, 2010 10:45 am

I use a French keyboard. If I type ^, I get ^^{}. The double ^^always appears. Also the menu command Command-Control-F is inactive, although Command-Control-G works as advertised. I have not defined any new commands.

Has this behaviour been observed by others?
Leuwen
 
Posts: 4
Joined: Sat Nov 13, 2010 10:39 am

Re: Keyboard shortcuts

Postby Leuwen » Sat Nov 13, 2010 2:16 pm

Sorry, the ^^ problem is just a feature of the French keyboard. The ^ is a special key in French, and TeXShop has to comply with that.
Leuwen
 
Posts: 4
Joined: Sat Nov 13, 2010 10:39 am

Re: Keyboard shortcuts

Postby Herbert Schulz » Sat Nov 13, 2010 2:25 pm

Howdy,

I assume you are talking about TeXShop's `Auto Complete' keybindings. the problem occurs because ^ is a special key with some non-English keyboards that looks for input of the next key. You can either turn Auto Complete off by unchecking TeXshop->Preferences->Source->Editor->Auto Complete or edit the completion file to remove the extra ^. To do the latter you need to open ~/Library/TeXShop/Keyboard/autocompletion.plist (~/Library/ is the Library folder in your HOME folder) in UTF-8 Unicode mode, look for the lines

<key>^</key>
<string>^{#SEL##INS#}</string>

remove the ^ from the second line

<key>^</key>
<string>{#SEL##INS#}</string>

and save the file.

I don't know why Ctl-Cmd-F is inactive but you can also use Opt-Trigger (where Trigger is Esc by default but may be changed to Tab in TeXshop->Preferences->Source->Command Completion Triggered By:).
Good Luck,
Herb Schulz
Herbert Schulz
 
Posts: 1489
Joined: Thu May 12, 2005 2:31 pm

Re: Keyboard shortcuts

Postby Leuwen » Wed Nov 17, 2010 10:09 am

I did as you suggested for ^and it worked perfectly. I would have liked to have ^{}• with the bullet after } to exit using escape or tab. However, if I type • in the Automatic completion files, it immediately changes • to \bullet, which is not what I want.

Can I do something about this? Or can you introduce the • in the next version.

Thanks a lot!
Leuwen
 
Posts: 4
Joined: Sat Nov 13, 2010 10:39 am

Re: Keyboard shortcuts

Postby Herbert Schulz » Wed Nov 17, 2010 1:12 pm

Howdy,

The changing of • to \bullet is also part of Auto Completion. You turn off Auto Completion (see the my message above) or, again, edit the autocompletion.plist file to remove the two lines associated with that binding. You can also generate a • by using Source->Completion->Marks->Insert Mark (Cmd-8) which was added to the Command Completion for just this reason.

Note: Command Completion is not the same thing as Auto Completion---you can get more information from the ``TeXShop Tips & Tricks'' document you can get as TeXShopTips-0.1.4.zip from <http://public.me.com/herbs2>. There are also a couple of Quick Start guides there for Command Completion and using latexmk.
Good Luck,
Herb Schulz
Herbert Schulz
 
Posts: 1489
Joined: Thu May 12, 2005 2:31 pm

Re: Keyboard shortcuts

Postby Leuwen » Tue Nov 30, 2010 2:45 pm

I did as you suggested. The bullets are now in 'Keyboard completion'. However when I use autocompletion, the bullets appear as 'Yen' (the Japanese money). I tried to delete the
<key>å</key>
<string>\aa</string>

in the autocompletion file, but I still get the Japanese money...

Thank you so much for helping me in this.
Leuwen
 
Posts: 4
Joined: Sat Nov 13, 2010 10:39 am

Re: Keyboard shortcuts

Postby Herbert Schulz » Tue Nov 30, 2010 3:19 pm

Howdy,

Well, it looks as though you didn't edit the file in UTF-8 encoding. You may have to remove the ~/Library/TeXShop/Keyboard/ folder and restart TeXShop to generate the default file again. You'll then have to edit the file all over again.
Good Luck,
Herb Schulz
Herbert Schulz
 
Posts: 1489
Joined: Thu May 12, 2005 2:31 pm


Return to TeXShop (engl.)

Who is online

Users browsing this forum: PhilipJursE and 1 guest

cron