Placing a special character ø from keyboard

The official TeXShop Support Forum.

Placing a special character ø from keyboard

Postby frodojedi » Tue Feb 22, 2011 10:48 pm

Hello,
I am not able to run this example inside TeXshop. Could you please help me?


Code: Select all
\documentclass[11pt,a4paper,onecolumn]{report}

\usepackage[francais,german,danish,english]{babel}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}

\title{Error}
\author{Frodo}
\date{February }

\begin{document}

%\maketitle

\chapter{Example}

\section{Special characters}
I want to type ø and having the same behavior of typing \o.

\end{document}


When running thi example I get an error saying that the charcter is not recognized.

Actually, if I create a .tex file using another editor with UTF8 encoding, and then I open it with TexShop instead of the character ø I get this characters √∏
If at this point I complie it there is no error.

I even tried to change the settings in TexShop but with no luck.

I also added the line % !TEX encoding = IsoLatin


Please help!
frodojedi
 
Posts: 3
Joined: Tue Feb 22, 2011 10:26 pm

Re: Placing a special character ø from keyboard

Postby Herbert Schulz » Wed Feb 23, 2011 4:29 pm

Howdy,

By default TeXShop saves files using MacOSRoman encoding, not UTF-8 Unicode encoding. Unless you have changed the default behavior that is the problem.

One way to fix this is to create a new file with the line

% !TEX encoding = UTF-8 Unicode

near the top of the file. Then Copy and Paste the contents of the old file into the new file and Save it. This tells TeXShop to use UTF-8 Unicode encoding to Save the file and also to read the file back into TeXShop.

An alternative is to tell the inputenc package that you are using MacOSRoman encoding in your file by using the line

\usepackage[applemac]{inputenc}

instead of what you have.

You can change the default behavior of TeXShop in TeXShop->Preferences->Source->Encoding. My tendency is to always use the ``encoding'' line which overrides and default in TeXShop since I use several different encodings to do testing.
Good Luck,
Herb Schulz
Herbert Schulz
 
Posts: 1489
Joined: Thu May 12, 2005 2:31 pm

Re: Placing a special character ø from keyboard

Postby frodojedi » Wed Feb 23, 2011 7:37 pm

Hello,
thanks for the answer. I literally followed your instructions but unfortunately both the method do not work at all.

This is the error that I get:

Code: Select all
Chapter 1.
! Undefined control sequence.
l.23 I type \UTF
                {00F8} and having the same behavior of typing \o.
?



Any suggestion?

Thanks in advance
frodojedi
 
Posts: 3
Joined: Tue Feb 22, 2011 10:26 pm

Re: Placing a special character ø from keyboard

Postby Herbert Schulz » Wed Feb 23, 2011 7:46 pm

Howdy,

Please UNCHECK TeXShop->Preferences->Misc->pTeX support-> utf export. That option is to be set ONLY if you use pTeX, a special version of TeX used in Japanese typesetting. I'm not sure but you probably have to start all over again since all the non-ascii character have been translated to those \UTF{...} codes.
Good Luck,
Herb Schulz
Herbert Schulz
 
Posts: 1489
Joined: Thu May 12, 2005 2:31 pm

Re: Placing a special character ø from keyboard

Postby frodojedi » Wed Feb 23, 2011 8:37 pm

NOW IT WORKS!!!

Thanks
frodojedi
 
Posts: 3
Joined: Tue Feb 22, 2011 10:26 pm


Return to TeXShop (engl.)

Who is online

Users browsing this forum: SabinaMa and 1 guest

cron