Bypass %!TEX TS-program = ...

The official TeXShop Support Forum.

Bypass %!TEX TS-program = ...

Postby flup » Sun Feb 05, 2012 9:48 am

Hello,

I often use the "magic comment " %!TEX TS-program = ... to specify an engine (for instance pdflatex).

But when I need to run biber or makeindex, the "%!TEX TS-program = ..." line make impossible to run biber or makeindex without removing that line.

This isn't the cas with TeXworks, where the comment line is "synced" with the dropdown engine menu.

Is there a simple solution to keep the "%!TEX TS-program = ..." comfort while being able to run other engines ? I guess latexmk could be a way, but a sync between that line a the dropdown engine menu (and the priority of the engine menu to the comment line) could also be an interesting solution.

Thanks for your ideas.
flup
 
Posts: 1
Joined: Sun Feb 05, 2012 9:39 am

Re: Bypass %!TEX TS-program = ...

Postby Herbert Schulz » Sun Feb 05, 2012 1:01 pm

Howdy,

I use the (pdf/xe)latexmk engines all the time so I think that's a great solution. If that's not something you want to do doesn't a direct run of ``bibtex'', Typeset->BibTeX (Shift-Cmd-B), do the job? Of course, to use biber rather than bibtex when that command is run you'd have to set biber as your BibTeX Engine (TeXShop->Preferences->Engine->BibTeX Engine) while the (pdf/xe)latexmk engines switch to biber automatically when they detect that it should be used from the biblatex output. You can also run makeindex by using Typeset->MakeIndex (Shift-Cmd-I).
Good Luck,
Herb Schulz
Herbert Schulz
 
Posts: 1489
Joined: Thu May 12, 2005 2:31 pm


Return to TeXShop (engl.)

Who is online

Users browsing this forum: DanteTwicy, IZLLatos, PenniSou and 1 guest

cron