[OS X Emacs] Switching from Carbon Emacs to Emacs.app

Lindsay Stirton Lindsay.Stirton at manchester.ac.uk
Wed Jan 9 05:16:29 EST 2008

OK, I tried to have a look at installing AUCTeX and Preview-LaTeX last 
night. I
made some progress, based largely on Pete Dyballa’s advice--but not so much
progress as to get the thing working.

First, not that this was the problem, but I installed MacTeX instead of gwTeX.
Then, I tried to compile AUCTeX. First I tried

Macintosh-3:auctex-11.84 ljs$ ./configure --with-lispdir=/Library/Application\
Support/emacs/ --with-emacs=/Applications/Emacs.app/Contents/MacOS/Emacs

That was not successful. However, when I left out

it seemed to compiled and install fine, so fat as I can tell.
Now, when I open a .tex file, AUCTeX’s LaTeX-mode starts. However, when I try
to pdf something, it doesn’t work. Here is the error message:

Running `LaTeX' on `TMA01' with ``pdflatex  -interaction=nonstopmode "\input"
/bin/sh: pdflatex: command not found
LaTeX exited abnormally with code 127 at Tue Jan  8 22:03:40

Next, I followed Pete Dyballa’s suggestion, and started emacs from the command
line, without the init files, using

/Applications/Emacs.app/Contents/MacOS/Emacs -Q &

and evaluating from the scratch butter

(add-to-list 'load-path (expand-file-name "/Library/Application 
(load "auctex.el" nil t t)
(load "preview-latex.el" nil t t)
Next I tried to LaTeX the same document. Success!
Type `C-c C-l' to display results of compilation.
You should run LaTeX again to get references right, {10} pages.
Type `C-c C-l' to display results of compilation.
LaTeX: successfully formatted {10} pages.

However, when I tried to use preview-latex I get the following error

! Emergency stop.
<to be read again>
<*> &prv_TMA01 _r
!  ==> Fatal error occurred, no output PDF file produced!
Transcript written on texput.log.

Preview-LaTeX exited as expected with code 1 at Tue Jan  8 22:11:57
LaTeX: LaTeX found no preview images

No success here, unfortunately. In any case, I am not sure what conclusions to
draw from this other than (tentatively) that AUCTeX and Preview-LaTeX have
built OK, but I need to setup my .emacs.

As usual, thanks for all the help so far. Any further help greatly valued.


More information about the MacOSX-Emacs mailing list