[OS X Emacs] Overriding emacs-rails included with Aquamacs

Chap Lovejoy chaplovejoy at gmail.com
Tue Nov 11 21:09:13 EST 2008


I'm trying to update to a newer revision of emacs-rails than that
included with the Aquamacs 1.5 distribution. I've placed the updated
emacs-rails files in:
~/Library/Application Support/Aquamacs Emacs/site-lisp/emacs-rails

However, this ends up in the load-path after /Applications/Aquamacs
Emacs.app/Contents/Resources/site-lisp/edit-modes/emacs-rails and the
older version continues to load. From what I've found through
searching the list it sounds like my user site-lisp directory should
be used before the one in the app bundle. (I've confirmed that the app
bundle one is getting loaded with find-library.)

Does anyone have any ideas how to get my version to load properly?
I've temporarily removed the one from the app bundle, but I'd prefer
to not do this so that I don't have a repeat of this problem when the
app is updated.


More information about the MacOSX-Emacs mailing list