[OS X Emacs] Unknown Color - Aquamacs 2.0

David Reitter david.reitter at gmail.com
Mon Jun 28 15:26:38 EDT 2010


a few color codes have changed between Carbon Emacs 22 and Cocoa (NS) Emacs 23.
This should not really lead to crashes...

If you compile with

./configure --with-ns CFLAGS='-g -O0'
make install

you should get good traces so you can pinpoint the location of the `abort' or crash.

gdb can help, too (but compile it as above for best results).

Hope that helps.

- David

On Jun 28, 2010, at 2:44 PM, Evan O'Connor wrote:

> Hello All,
> I've recently tried several times to install the new Aquamacs 2.0 (I'm really looking forward to the spell checker, I've tried to get it working so many times...)  I have OS X 10.5.8.
> I ran the installation, everything worked great except when I got to launch the program it crashes immediately.  I've since tried installing from the source code and same thing.  I can successfully run
> src/emacs -nw
> in the install directory but
> src/emacs -Q
> crashes and gives me the error "Unknown color".  I expect this is the reason for the Aquamacs.app crashing as well.  I've searched through the code to find this error (looks like it orginates in nsfns.m) but I'm at a loss as to why I'm getting it.
> Thoughts?
> Thanks,
> Evan

More information about the MacOSX-Emacs mailing list