[OS X Emacs] Re: Any Word On Emacs 24?

Piet van Oostrum piet at vanoostrum.org
Thu Sep 15 15:38:49 EDT 2011

Peter Dyballa <Peter_Dyballa at Web.DE> writes:

> Am 14.09.2011 um 15:37 schrieb Piet van Oostrum:
>> I tried this one to check a problem that I have with Aquamacs: Curly single
>> quotes are not displayed properly on Mac OS X Snow Leopard (10.6.8, but
>> also earlier versions).
> Piet,
> this problems exists as well in the native NS (Aqua) variant of GNU
> Emacs 24.0.50. 

Actually that was the version I checked and reported. I had reported
Aquamacs before.

> You can check with C-u C-x =, with the text cursor on
> that character, which font is used to display that character. The
> quotes are taken from Apple Symbols. M-x describe-fontset RET reports
> similarly. I've tried to cure the problem with a statement like:
>     (set-fontset-font (frame-parameter nil 'font) '(#x2018 . #x201E)
> 		      "FreeMono" nil 'prepend)
> ("Monospace" might also be useful), but it does not work. M-x describe-fontset RET does report the change, but it's not expressed on screen. What does work is using FreeMono as font. This overrides the use of Apple Symbols.

I installed FreeMono, and changed to it (Using Aquamacs 2.3a – I had
other reasons to go back to it), but surprisingly when I check
the font of normal letters then it appears to be Times Roman, whereas
the quotes are still Symbol. So FreeMono doesn't seem to be accepted by
my Aquamacs, although. So the problem remains.

Even when FreeMono would have solved it it is still a bug IMHO.
Piet van Oostrum <piet at vanoostrum.org>
WWW: http://pietvanoostrum.com/
PGP key: [8DAE142BE17999C4]

More information about the MacOSX-Emacs mailing list