[OS X Emacs] problem with updating packages

Win Treese treese at acm.org
Tue May 19 15:38:08 EDT 2020

Hi, Johannes.

That error means that one or more packages that you are trying to upgrade now requires Emacs 26.1 as a the oldest version supported, and Aquamacs 3.x is based on Emacs 25.

I hope to have a version of Aquamacs based on Emacs 26 available later this year.

It’s hard to give general advice about how to avoid getting the error, although perhaps other list members have some thoughts about that. Otherwise, if you want to email me off list to try to figure it out, feel free.

- Win

Win Treese
treese at acm.org
Aquamacs maintainer

> On May 17, 2020, at 7:16 PM, Johannes Brauer <brauer at nordakademie.de> wrote:
> Hi!
> Using list-packages and mark all available upgrades 17 packages are marked or upgrading. Trying to upgrade these packages the following error message is shown:
> Package ‘emacs-26.1’ is unavailable
> I am using Aquamacs 3.5  GNU Emacs (x86_64-apple-darwin16.7.0, NS, macOs 10.15.4
> I have no idea what I could do. Any help?
> Johannes
> _____________________________________________________________
> MacOSX-Emacs mailing list
> MacOSX-Emacs at email.esm.psu.edu
> https://email.esm.psu.edu/mailman/listinfo/macosx-emacs
> List Archives: http://dir.gmane.org/gmane.emacs.macintosh.osx

More information about the MacOSX-Emacs mailing list