[OS X Emacs] problem with updating packages
treese at acm.org
Wed May 20 23:38:49 EDT 2020
Hi, Johannes. I went exploring in the package system and found out a few things. I’m not completely clear on a couple of subtle points, but here’s what I think is going on.
Aquamacs wants to upgrade helm-bibtex because there’s a new version. helm-bibtex requires bibtex-completion, and there’s a new version of that depends on Emacs 26. When Aquamacs tries to update helm-bibtex, it runs into the problem that it can’t update bibtex-completion, so it throws the error.
However, helm-bibtex doesn’t actually need the newer version of bibtex-completion; it’s perfectly happy with the old one.
I think if you put this in your config, it will keep bibtex-completion from being updated, and then things should be fine, at least until another problem like this shows up:
(setq package-load-list ‘((bibtex-completion “2.0.0”) all)
Or you can use customize to change it to that value. What this does is to “hold” the version of bibtex-completion at 2.0.0 (which is the likely one you have—you can see the actual value you need in the package buffer).
This should keep things OK for now, and then you can remove it once we have moved Aquamacs up to Emacs 26.
This depends a lot on your configuration, so some of the details may not quite be right.
If anyone else knows more about this, please speak up!
> On May 20, 2020, at 9:53 AM, Johannes Brauer <brauer at nordakademie.de> wrote:
> Hi Win,
> this is the list:
> 17 packages marked for upgrading.
> Upgrade these 17 packages (ace-window-20200311.1025, aggressive-indent-20200512.1207, auctex-12.2.1, avy-20200519.1007, biblio-20200416.1407, biblio-core-20200416.307, cider-0.24.0, clojure-mode-20200419.559, clojure-mode-extra-font-locking-20200320.823, company-20200510.1614, counsel-20200519.1447, dash-20200426.2244, elm-mode-20200406.214, flycheck-20200516.1719, git-commit-20200516.2016, helm-20200517.509, helm-bibtex-20200429.1606)?
>> Am 19.05.2020 um 21:38 schrieb Win Treese <treese at acm.org>:
>> Hi, Johannes.
>> That error means that one or more packages that you are trying to upgrade now requires Emacs 26.1 as a the oldest version supported, and Aquamacs 3.x is based on Emacs 25.
>> I hope to have a version of Aquamacs based on Emacs 26 available later this year.
>> It’s hard to give general advice about how to avoid getting the error, although perhaps other list members have some thoughts about that. Otherwise, if you want to email me off list to try to figure it out, feel free.
>> - Win
>> Win Treese
>> treese at acm.org
>> Aquamacs maintainer
>>> On May 17, 2020, at 7:16 PM, Johannes Brauer <brauer at nordakademie.de> wrote:
>>> Using list-packages and mark all available upgrades 17 packages are marked or upgrading. Trying to upgrade these packages the following error message is shown:
>>> Package ‘emacs-26.1’ is unavailable
>>> I am using Aquamacs 3.5 GNU Emacs 126.96.36.199 (x86_64-apple-darwin16.7.0, NS, macOs 10.15.4
>>> I have no idea what I could do. Any help?
>>> MacOSX-Emacs mailing list
>>> MacOSX-Emacs at email.esm.psu.edu
>>> List Archives: http://dir.gmane.org/gmane.emacs.macintosh.osx
>> MacOSX-Emacs mailing list
>> MacOSX-Emacs at email.esm.psu.edu
>> List Archives: http://dir.gmane.org/gmane.emacs.macintosh.osx
> MacOSX-Emacs mailing list
> MacOSX-Emacs at email.esm.psu.edu
> List Archives: http://dir.gmane.org/gmane.emacs.macintosh.osx
More information about the MacOSX-Emacs