[OS X Emacs] New problem with MELPA on Aquamacs (Win Treese)

Robert Goldman rpgoldman at sift.info
Tue Jan 5 15:14:40 EST 2021

> From: Win Treese <treese at acm.org>
> To: Emacs on Mac OS X Mailing List <macosx-emacs at email.esm.psu.edu>
> Subject: Re: [OS X Emacs] New problem with MELPA on Aquamacs
> Message-ID: <2FE93F3F-D9B9-43A2-91F6-7F41511A6586 at acm.org>
> Content-Type: text/plain;	charset=utf-8
>> On Jan 4, 2021, at 11:59 AM, Robert Goldman <rpgoldman at sift.info> 
>> wrote:
>> I tried to install the MELPA package conda, version 20200818.1614. 
>> This failed, and I see this in *Messages*:
>> package-install-from-archive: 
>> https://melpa.org/packages/f-20191110.1357.el: Bad Request
> Hi, Robert. This looks pretty mysterious, and I think the following 
> will correct it:
> (setq gnutls-algorithm-priority "NORMAL:-VERS-TLS1.3?)
> This has to do with how the SSL/TLS protocol is negotiated between 
> Aquamacs using GNUtls and the MELPA server, and it shows up as a ?Bad 
> request? error.
> If anyone is interested, if you set url-debug to t, it tells you a lot 
> about what is going on under the covers for web requests, although it 
> doesn?t by itself tell you enough to figure out the TLS thing.
> Aquamacs 3.6 will have this set by default.

Thanks, Win! That solved my problem.  Note for the rest of the list that 
somewhere on the email chain garbled the above, so that the close quote 
got changed into a question mark.


More information about the MacOSX-Emacs mailing list