[OS X TeX] Unable to install TeX Foundation and Programs

Henrik Holm list at henrikholm.com
Fri Nov 15 20:38:23 EST 2002

I downloaded the TeX-fat.dmg, and started installing teTeX using the new
installer.  Sadly, it seems to stop at the configuration point.  I think
I have the latest files available, because at an early stage the
installer asked whether I wnated to have newer files downloaded, which i
responded positively to.

At my latest attempt, I first installed the TeX Foundation package
('texmf.ii2').  It stops before the configuration step, with the message

  "TeX Programs Unavailable: TeX cannot be configured [...] when both
foundation and programs have been installed (in either order) will the
configuration script proceed"

I then proceeded to install the Tex Programs package
('texbinaries.ii2').  After some time, the log window says,

  ### texbinaries.configure: Started...
  ### texbinaries.configure: /usr/local/teTeX/share/texmf.local does not
exist. Creating.
  ### texbinaries.configure: /usr/local/teTeX/texmf.cnf does not exist.
Creating default.

Then, the installer seems to hang.  I assume it is not that it just
takes a lot of time; the i-Installer does not take a lot of resources
(as reported by a 'top -u') -- and the CPU load is quite low.  I look in
the 'Activity Window', and it says that process
23102:texbinaries.configure is running, and that 'stopDOServer' is
waiting.  This goes on for several minutes until I get sufficiently
annoyed, mark the configure process and click 'Abort'.  Naturally, the
i-Installer tells me that the installation finished with fatal errors.

Doing it in the opposite way, i.e., uninstalling everything and
attempting to install the Programs first yields the same result: the
Foundation installer window seems to hang.

I have tried running pdfLaTeX after quitting the installer, and sure
enough; it does not work, and claims that 'pdflatex.fmt' is not to be

Am I doing something wrong here?  Is there anything wrong with my setup?
I do have Fink installed -- but I have uninstalled the system-tetex Fink

Any help greatly appreciated.

Henrik Holm

Mac TeX info, resources, and news can be found at:
List archives can be found at:
See message headers for list info.

More information about the MacOSX-TeX mailing list