[OS X TeX] 10.2 permissions/crash/Apple doc

Axel E. Retif axretif at att.net.mx
Wed Sep 11 08:29:13 EDT 2002


On Monday, September 9, 2002, at 11:44  PM, Richard Seguin wrote:


> Why would repairing permissions bring the finder back? Why are my 
> permissions getting corrupted in the first place? Bizarre. At the 
> moment, I'm crossing my fingers that I won't get another blank screen 
> in the morning when I power up.

We haven't heard from you. I wish I could be more helpful, but --being a 
copy-editor by trade, user of the now Classic Mac OS since System 3 (I 
think) and QuarkXPress, etc.-- all I can do is point you to some pages; 
for example,


a (basic) AppleCare document on permissions, and


a MacInTouch report where Daniel Paawe describes his experiences 
upgrading different machines.

When Mac OS X came out, I regretted not having learned (La)TeX years ago 
(that's why I said elsewhere that I wish I were a TeXnician like most of 
you, not to say a TeXpert like a few of you, or the real TeXGurus, like 
Mr. Wierda).

So, with the very first release of TeXShop, I decided to try it. In the 
pre-Wierda's days (and OS X 10.0), I downloaded the .tar distribution of 
Thomas Esser's teTeX. I installed it and after rebooting... I almost  
could not use my machine. So I erased my partition and reinstalled 
everything (System and all) and tried again with teTeX. Same result, 
same reinstalling everything.

Well --by the third time, I knew I had to find out what was going on and 
fix things myself. All the problems were related to privileges (a.k.a. 
permissions), so with Terminal.app I started changing all I thought 
needed to be changed (you know -- sudo chown <user> <group> <file>). And 
it worked!

Then came Fink, and I installed teTeX through it, then Fink distribution 
of Wierda's distribution, and then Wierda's with his installers. In my 
PowerBook with 10.2 I haven't reinstalled Fink, but I have Wierda's 
distribution running without any problems.

Now you don't have to use chown --the RepairPrivileges utility (for 
System 10.1.5) and Disk Utility "Repair Disk Permissions" (for System 
10.2) supposedly do that for you.

One more thing, about fsck -y (if you use it) --while it is true that 
when you boot (or reboot) your machine OS X does fsck, if your disk 
needs repairing you have to use fsck more than once. That's why the best 
thing to do is to boot in Single User Mode (cmd-s) and do fsck -y when 
prompted, and, if you get the message that your disk has been repaired, 
do it once more, until you get the message that your disk (partition) is 

But as Nick points out in "OT:Re: [OS X TeX] More about UFS",

> And yes, HFS+ is prone to various problems that fsck_hfs, or Disk First 
> Aid, can't fix. DiskWarrior can fix much more

I use DiskWarrior both on OS 9 as OS X machines, and I really think he's 


Mac TeX info, resources, and news can be found at:
List archives can be found at:
Threaded list archives can be found at:
See message headers for list info.

More information about the MacOSX-TeX mailing list