[OS X TeX] Re: The .enc problem

Gerben Wierda Gerben.Wierda at rna.nl
Thu Dec 30 10:46:21 EST 2004

I am cc-ing the list because of the fact that in your case the problem  
is solved now after a uninstall/reinstall cycle.

On Dec 30, 2004, at 16:16, Simon Spiegel wrote:

> Ok, de-installing TeX and installing TL20005 finally did the trick. It  
> works now. My results are attached...
> Thank you
> simon
> Here are my results:
> simi_/Users/simi: kpsewhich --expand-braces \$ENCFONTS
> .:/Users/simi/Library/texmf/fonts/enc//:!!/usr/local/teTeX/share/ 
> texmf.local/fonts/enc//:!!/usr/local/teTeX/share/texmf.gwtex/fonts/ 
> enc//:!!/usr/local/teTeX/share/texmf.tetex/fonts/enc//:!!/usr/local/ 
> teTeX/share/texmf/fonts/enc//
> simi_/Users/simi:
> simi_/Users/simi: grep ENCFONTS  
> /usr/local/teTeX/share/texmf/web2c/texmf.cnf
> ENCFONTS = .;$TEXMF/fonts/enc//
> simi_/Users/simi: env
> HOME=/Users/simi
> SHELL=/bin/tcsh
> USER=simi
> PATH=/Users/simi/bin/powerpc-apple-darwin:/Users/simi/bin:/usr/local/ 
> bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/usr/X11R6/bin:/sw/ 
> bin:/Developer/Tools:/Users/simi/bin:/usr/local/bin:/usr/local/teTeX/ 
> bin/powerpc-apple-darwin-current:.
> TERM_PROGRAM=Apple_Terminal
> TERM=vt100
> HOSTTYPE=powermac
> VENDOR=apple
> OSTYPE=darwin
> MACHTYPE=powerpc
> PWD=/Users/simi
> LOGNAME=simi
> GROUP=staff
> HOST=simi-computer.local
> MANPATH=/Users/simi/man:/usr/local/share/man:/usr/share/man:/usr/ 
> X11R6/man:/usr/local/man:/usr/share/man
> INFOPATH=/sw/share/info:/sw/info:/usr/share/info
> PERL5LIB=/sw/lib/perl5:/sw/lib/perl5/darwin
> XML_CATALOG_FILES=/sw/etc/xml/catalog
> SGML_CATALOG_FILES=/sw/etc/sgml/catalog
> QTDIR=/sw
> QMAKESPEC=/sw/share/qt3/mkspecs/darwin-g++
> XDG_DATA_DIRS=/sw/share
> XDG_DATA_HOME=/sw/share

Your environment is not perfect:
1. Setting a MANPATH env variable will disable man from working  
properly in Mac OS X 10.2 and up. The TeX man pages will not be visible  
with your use of MANPATH as I edit /etc/manpath.config which is  
overruled by your MANPATH setting.
2. Your PATH is weird. /usr/local/bin (and certainly your personal  
directories) before the system directories is a security risk, /sw/bin  
after them is incorrect for Fink to work properly

The fact that you had this problem and not anymore seems to me a matter  
of this system config and there is no guarantee TeX will stay working.  
That it did not work may have nothing to do with your system setup but  
we are too late to find out what caused the problem (e.g. if you had  
accidentaly changed the install location you would have been working  
with the old setup all the time) but we cannot check that anymore.

For others with problems: please try to create an i-Installer report at  
the end of an install. The mail button does not work on large reports  
(Apple problem) but copy and paste into a mail message does work.


--------------------- Info ---------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
           & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Post: <mailto:MacOSX-TeX at email.esm.psu.edu>

More information about the MacOSX-TeX mailing list