[OS X TeX] kpsewhich .enc strange

Bernhard Barkow bb at creativeeyes.at
Thu Dec 30 12:27:43 EST 2004

I found the same problem in my fresh installation, getting the message:
Warning: pdflatex (file 8r.enc): cannot open encoding file for reading

Something similar happens when using dvips:
Warning: module writet1 of dvips (file 8r.enc): cannot open encoding 
file for reading

This does not happen when using standard CM fonts. I just noticed it 
with Adobe Garamond fonts I tried to install into teTeX, and I am not 
100% sure that everything works fine with these newly added fonts 
(although it should). However, something should be wrong, because

kpsewhich -progname=pdftex 8r.enc
kpsewhich -progname=dvips 8r.enc
both produce no result, i.e., 8r.enc is not in the search path. I 
definitely don't know enough about fonts in LaTeX, but I guess this 
might be one source of the problem.

On 30. Dez 2004, at 17:45, Curtis Clifton wrote:

> Gerben,
> I see that Simon has succeeded in getting TL2005 install working, so 
> perhaps I should go that route.  However, something is clearly broken 
> in the TL2004 "Stable" install and I'm stubborn enough to want to help 
> you fix these bugs.  Please note that I am using the TUG i-Directory.
> I'm starting with a clean install of the TeX i-Package dated June 
> 2004, before you integrated TL2004 into the TeX i-Package.  This old 
> i-Package installs and works without any problems.
> I did the following:
> 1. I uninstalled the TeX i-Package.  (i-Installer reported that the 
> remote package was more current, so I updated before uninstalling.)
> 2. I verified that /usr/local/teTeX no longer existed on my machine. 
> (i-Installer bug: the Pkg Properties tab does not update the Installed 
> line to show "No installation found".)
> 3. I tried to run Install and Configure of the TeX i-Package.  This 
> failed.  The Subprocess Output error window shows:
> Can't locate 
> /Users/cclifton/Documents/i-Packages/tex.ii2/tex.sharedscript.pm in 
> @INC (@INC contains: 
> /System/Library/Perl/5.8.1/darwin-thread-multi-2level 
> /System/Library/Perl/5.8.1 
> /Library/Perl/5.8.1/darwin-thread-multi-2level /Library/Perl/5.8.1 
> /Library/Perl /Network/Library/Perl/5.8.1/darwin-thread-multi-2level 
> /Network/Library/Perl/5.8.1 /Network/Library/Perl .) at 
> /Users/cclifton/Documents/i-Packages/tex.ii2/tex.selector line 18.
> There appears to be a problem with updating from the June TeX 
> i-Package to the most recent one.  The tex.sharedscript.pm file, among 
> others, is not downloaded.  I have reported this problem to you 
> off-list previously and have duplicated the problem three times using 
> the procedure described above.  You may not be interested in fixing 
> this bug, but should at least acknowledge it in either the package 
> description or on your website.
> To get past this bug, it is necessary to exit i-Installer and delete 
> the TeX i-Package from my ~/Documents/i-Packages directory.  So I did 
> so and continued as follows:
> 1. I opened the TeX i-Package from TUG.
> 2. I ran Install and Configure with the following options:
> 	Full
> 	2004 Stable
> 	Paper size: chose letter, clicked Set
> 3. In Terminal, I opened on a new shell, cd to the directory 
> containing my minimal fourier sample file, and ran `pdflatex sample`.  
> This failed, with the key bit of the log being: Warning: pdflatex 
> (file 8r.enc): cannot open encoding file for reading
> Having re-established the broken installation, I tried all the various 
> queries on the environment that you've suggested in the threads on 
> this topic.  The full transcript of these follows my signature below.  
> But the interesting bits are that:
> - My environment contains only one variable related to TeX: 
> TEXEDIT=bbedit +%d %s
> - The ENCFONTS variable does not appear in texmf.cnf as demonstrated 
> by the following transcript:
> [cclifton]$ find /usr/local/teTeX -name texmf.cnf
> /usr/local/teTeX/share/texmf/web2c/texmf.cnf
> /usr/local/teTeX/texmf.cnf
> [cclifton]$ grep ENCFONTS /usr/local/teTeX/share/texmf/web2c/texmf.cnf
> [cclifton]$ grep ENCFONTS /usr/local/teTeX/texmf.cnf
> [cclifton]$
> The transcript below contains a listing of both texmf.cnf files.  
> You'll note that the /usr/local/teTeX/share/texmf/web2c/texmf.cnf file 
> includes hardwired references to /usr/local/Build.  I suspect that the 
> i-Package is failing to generate the correct texmf.cnf for the TL2004 
> Stable install.
> Your posts to the list seem to indicate that you believe this problem 
> is entirely due to user error (esp. with regard to environment 
> variables).  However, the other common factor is that TL2004 Stable 
> does not work, but TL2005 Devel. does work.
> I will send the i-Installer report off list.
> Curt

--------------------- Info ---------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
           & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Post: <mailto:MacOSX-TeX at email.esm.psu.edu>

More information about the MacOSX-TeX mailing list