[OS X TeX] a problem with pdftricks

Sergei Mariev serguei.mariev at campus.lmu.de
Wed Apr 6 11:07:48 EDT 2005

Thanks a lot, Herb, but I just seem to run into problems again. The 
code I am trying to produce and to test is just the first simplest 
example from the pstricks manual. Everybody on the list reports that 
this code works just fine. I have several  things with pstricks in 
the past and did not have any problems; so I am wondering what I am 
doing wrong now or what is going wrong on my computer since I just 
can't get it to work properly?!? More concretly: if I run on my 
mashine the file which you posted I get the message:
! pdfTeX error (ext1): invalid image dimensions.
<argument> ... page \GPT at page \fi {\Gin at base .pdf}
                                                   \setbox \@tempboxa =\hbox ...
l.29 \end{pdfpic}

and no pages of output. Here is the entire log:

This is pdfeTeXk, Version 3.141592-1.11b-2.1 (Web2C 7.5.2)
  \write18 enabled.
  %&-line parsing enabled.
entering extended mode
LaTeX2e <2001/06/01>
Babel <v3.7h> and hyphenation patterns for american, british, french, german, n
german, greek, italian, latin, russian, spanish, nohyphenation, loaded.
Document Class: article 2001/04/21 v1.4e Standard LaTeX document class

Package pdftricks Warning: ****************************************
(pdftricks)                Package pdftricks v,1.16.2 loaded
(pdftricks)                [psTricks support in PDF (CVR, ACL), processing chan
ges (HS)]
(pdftricks)                ****************************************.


Package pdftricks Warning: ****************************************
(pdftricks)                Using \write 18 capability
(pdftricks)                for producing PDF-figures.
(pdftricks)                ****************************************.


! Package babel Error: You haven't defined the language english yet.

See the babel package documentation for explanation.
Type  H <return>  for immediate help.
l.3 \select at language{english}
) (/usr/local/teTeX/share/texmf.tetex/tex/context/base/supp-pdf.tex
loading : Context Support Macros / Missing
loading : Context Support Macros / PDF
) Opening PDFStream=figure-fig1.tex### This is 
Version $Revision: 2.15 $
### /usr/local/teTeX/bin/powerpc-apple-darwin-current/latex figure-fig1
This is e-TeXk, Version 3.141592-2.1 (Web2C 7.5.2)
  %&-line parsing enabled.
entering extended mode
### /usr/local/teTeX/bin/powerpc-apple-darwin-current/dvips -R 
-Poutline  -o /tmp/altpdflatex.3611-1112799591/figure-fig1.ps 
This is dvips(k) 5.94a Copyright 2003 Radical Eye Software (www.radicaleye.com)
' TeX output 2005.04.06:1659' -> 
<pst-text.pro><special.pro>. [1]
### ps2pdf13 /tmp/altpdflatex.3611-1112799591/figure-fig1.ps 
### Copying/moving pdf file 
/tmp/altpdflatex.3611-1112799591/figure-fig1.pdf to figure-fig1.pdf
### Succesfully generated figure-fig1.dvi and figure-fig1.pdf
PDFCROP 1.5, 2004/06/24 - Copyright (c) 2002, 2004 by Heiko Oberdiek.
==> 1 pages written on `figure-fig1-crop.pdf'.

! pdfTeX error (ext1): invalid image dimensions.
<argument> ... page \GPT at page \fi {\Gin at base .pdf}
                                                   \setbox \@tempboxa =\hbox ...
l.29 \end{pdfpic}
No pages of output.
Transcript written on figure.log.

>On 4/4/05 7:40 PM, "Herb Schulz" <herbs at wideopenwest.com> wrote:
>>  Howdy,
>>  I'm sorry I couldn't reply earlier but I was off the net for the last week;
>>  the hinge holding the lcd onto the body of my old Powerbook actually snapped
>>  and the system was into Apple for repair.
>>  If I compile the following file it all seems to work fine for me:
>>  %&pdflatex
>>  \documentclass[10pt]{article}
>>  \usepackage{pdftricks}
>>  \begin{psinputs}
>>    \usepackage{pstricks-add}
>>    \usepackage{pstricks}
>>    \usepackage{rotating}
>>    \usepackage{pst-plot}
>>    \usepackage{pst-text,pst-node,pst-tree}
>>  \end{psinputs}
>>  \begin{document}
>>  \begin{pdfpic}
>>  \begin{pspicture}(0,0)(3.5,2.5)
>>  \psline(2,1)(3,2)
>>  \end{pspicture}
>>  \end{pdfpic}
>>  \end{document}
>>  Your original file with the \ifpdf stuff worked fine for me under pdflatex
>>  but not under patex+ghostcript because there was no
>>  \begin{psinputs}...\end{psinputs} but there still was the
>>  \usepackage{pdftricks} and \begin{pdfpic}...\end{pdfpic} environment
>>  surrounding the pspicture.
>>  You've got to be a bit fancier if you want it to work in both situations:
>>  put the \usepackage{pdftricks} inside the \ifpdf and in the \else clause
>>  you've got the define the pdfpic environment as an empty environment.
>>  ...
>Ok, here's a version of the file that works with both latex+ghostscript
>processing (via pstricks alone) or pdflatex (via pdftricks + pstricks):
>     \begin{psinputs}
>         \usepackage{pstricks-add}
>         \usepackage{pstricks}
>         \usepackage{rotating}
>         \usepackage{pst-plot}
>         \usepackage{pst-text,pst-node,pst-tree}
>     \end{psinputs}
>     \usepackage{pstricks-add}
>     \usepackage{pstricks}
>     \usepackage{rotating}
>     \usepackage{pst-plot}
>     \usepackage{pst-text,pst-node,pst-tree}
>     \newenvironment{pdfpic}{\begin{center}\mbox\bgroup}{\egroup\end{center}}
>Please note that the pdfpic environment defined in the pdftricks package
>puts the graphic (generated by making the file example-fig1.tex, etc.) in a
>centered box so that is what the defined environment does when using
>pstricks alone. I think the two methods then generate identical results.
>Good Luck,
>Herb Schulz
>(herbs at wideopenwest.com)
>--------------------- Info ---------------------
>Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
>            & FAQ: http://latex.yauh.de/faq/
>TeX FAQ: http://www.tex.ac.uk/faq
>List Post: <mailto:MacOSX-TeX at email.esm.psu.edu>

--------------------- Info ---------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
           & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Post: <mailto:MacOSX-TeX at email.esm.psu.edu>

More information about the MacOSX-TeX mailing list