[OS X TeX] makeidx error

Morten Høgholm morten.hoegholm at latex-project.org
Wed Apr 27 16:52:29 EDT 2005

On Wed, 27 Apr 2005 13:04:34 -0600, John Vokey <vokey at uleth.ca> wrote:

> I recently attempted to recompile a book that worked fine a year ago,  
> and got the following error while it attempts to load makeidx.sty:
> (/usr/local/teTeX/share/texmf.tetex/tex/latex/base/makeidx.sty
> ! LaTeX Error: Command \printindex already defined.
>                 Or name \end... illegal, see p.192 of the manual.
> See the LaTeX manual or LaTeX Companion for explanation.
> Type  H <return>  for immediate help.
>   ...
> l.43 ...command\printindex{\@input@{\jobname.ind}}
> I get the same error with a new document that attempts to use makeidx.sty
> Thinking my TeX installation was corrupted somehow, I re-installed (2004  
> stable) using the I-Installer.  Same error.  Anyone else getting this?

The only logical explanation is that something else defines \printindex  
and I would think your documentclass is the one doing it for you. Just  
forget about makeidx. All it does is this:

\newcommand*\see[2]{\emph{\seename} #1}
\providecommand*\seealso[2]{\emph{\alsoname} #1}
\providecommand*\alsoname{see also}

There is no reason why a document class shouldn't provide this natively  
these days, which is why several of them actually do it.
--------------------- Info ---------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
           & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Post: <mailto:MacOSX-TeX at email.esm.psu.edu>

More information about the MacOSX-TeX mailing list