[OS X TeX] Re: Flashmode-Alpha Trial version

Stefan Walsen stefan at walsen.net
Thu Jan 6 11:38:25 EST 2005

Claus Gerhardt wrote:
> Using "replaceText" as a name for the variable, was a vary bad choice, 
> since this term has a special meaning in tcl, but apparently without any 
> bad results.

That is because Tcl never sees the variable. the first occurrence of 
"replaceText" (right after the "eval") is just a string of characters 
for AppleScript (since it is "quoted"), and the second occurrence is 
identified as a variable and replaced with its contents ("{string2}") 
before concatenating the string and passing it to "DoScript".

>>     DoScript "eval replaceText " & "[search -r 0  " & findText & " " & 
>> "[minPos]]" & " " & "{" & replaceText & "}"

But maybe you should change it anyway in order to avoid confusion. :)

--------------------- Info ---------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
           & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Post: <mailto:MacOSX-TeX at email.esm.psu.edu>

More information about the MacOSX-TeX mailing list