[OS X TeX] font install July 6

Charles Chapman Pugh pugh at Math.Berkeley.EDU
Wed Jul 6 18:44:52 EDT 2005


I'm trying to install a type 1 postscript font for use with TexShop,  
2.03, running on Tiger 10.4.1  The font is a lwfn file and there is  
an afm file.  The font was named Csc and worked fine in Textures.

Following Bruno Voisin's guide, I renamed the font Cscr8a, and using  
the terminal window, succeeded in generating the file Cscr8a.pfb.

The three files, lwfn, afm, and pfb  all are in the same folder.  As  
instructed, in the same folder I created a file named Csc-drv.tex  
which contained the lines

input fontinst.sty

Bruno's next step is "Run TeX" on the file Csc-drv.tex to produce PL,  
VPL, and FD files.

My question  --  how?  I tried various combinations in the typeset  
menu of TeXShop.  All gave tex errors as noted in the console, except  
for plain tex with personal script.  In this case I got a message  
that the tool could not be found.  I guess the tool is fontinst.sty.   
But that file was indeed installed by the i-installer.  It's in the  
system library at location


(Actually that is the address given by the getinfo service.  I  
imagine this is the same address as the path


which is how it appears when opening iBook manually.)

Just for good measure, I put a copy of the "base" folder in a mirror  


but still tex did not find the tool.


Best,  Charles Pugh

BTW  There is an apparent misspelling in Bruno's guide.  It says that  
the  -drv.tex file should have the first line

input fontint.sty

as contrasted to fontinst.sty  I did try it this way also, just to be  
sure, but had no better luck.

--------------------- Info ---------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
           & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Post: <mailto:MacOSX-TeX at email.esm.psu.edu>

More information about the MacOSX-TeX mailing list