[OS X TeX] pstricks question

Aaron Jackson jackson at msrce.howard.edu
Wed Mar 16 20:48:30 EST 2005

On Mar 16, 2005, at 7:06 PM, Sergei Mariev wrote:

> I am trying to typeset a tree using  pstricks. I have the following 
> code:
>   \pstree[nodesep=2pt]{\Tr{EI}}{\Tr{P} \pstree{\Tr{a}}{\Tr{S}}}
> And I am getting the following error-message:
> PSTricks error.  See User's Guide for further information.
>                  Type  H <return>  for immediate help.
> ! Graphics parameter `nodesep=2pt' not defined..
> \@pstrickserr ... immediate help.}\errmessage {#1}
>                                                   \endgroup
> l.7     \pstree[nodesep=2pt]{\Tr{EI}}
>                                      {\Tr{P} \pstree{\Tr{a}}{\Tr{S}}}
> ? x
> In other words, it does not recognize the optional parameter 
> [nodesep=2pt] ...??? Do I need to load a  special package for this? 
> (Initially I tried loading just 
> \usepackage[]{pstricks,pst-plot,pst-node,pst-tree}) I also tried 
> \usepackage{pst-all} ... but it still does not seem to recognize this 
> optional nodesep parameter! Does anyone know what I am doing wrong?

You can't use pdflatex to process file that use pdftricks, unless you 
use pddftricks or ps4pdf.  This above example runs fine on my computer 
if i use latex.


--------------------- Info ---------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
           & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Post: <mailto:MacOSX-TeX at email.esm.psu.edu>

More information about the MacOSX-TeX mailing list