[OS X TeX] Pdftricks doesn't seem to fit with the new gwTeX distribution

Herbert Schulz herbs at wideopenwest.com
Sun Oct 2 17:43:08 EDT 2005

On Oct 2, 2005, at 2:54 PM, Herbert Schulz wrote:

> On Oct 2, 2005, at 2:30 PM, Franck Pastor wrote:
>> Hello everybody,
>> I have just installed the new gwTeX distribution (TeXLive 2005,  
>> PowerPc binary) and I've suddenly run into a strange problem, with  
>> a file containing a pstricks figure, compiled with pdfLaTeX using  
>> pdftricks (in fact, the Newpdftricks package by Herb Schulz). The  
>> figure takes a whole page of the document, only for itself. It  
>> happened with Newpdftricks, not with the original pdftricks  
>> package, and I don't have any problem if I run TeX+Ghostcript,  
>> without pdftricks of course. Here is an (oversimplified) short  
>> version of this figure :
>> ...
>> This simple source produces a three pages pdf document ! First a  
>> void page, then the figure and finally the short text... And more,  
>> with this simplified version, now not only Newpdftricks but also  
>> the original pdftricks produce that strange behavior !!
>> I'm completely lost... Any idea of what happened ?
> Howdy,
> I'll have to look into this. It fails with the installed pdftricks  
> as well as the one I re-wrote. I can see that pdfcrop seems to fail  
> when it tries to do a pdftex run but I'll have to look into the  
> pdfcrop script to see what's going on.
> Good Luck,
> Herb Schulz
> (herbs at wideopenwest.com)


I don't know if others have tried to use pdftex but I get an error  
with it with the TL2005 install. I didn't notice it before because I  
only use a personal format with pdftex and I already had rebuilt that.

There seems to be a problem with the production of the pdftex.fmt  
file so pdftex fails when pdfcrop tries to run it. As a VERY  
TEMPORARY fix you can do the following:

Open Terminal.app and run the command

pdfetex -ini --translate-file=cp227.tcx \*pdftex.ini

which will produce a pdftex.fmt and pdftex.log file in your home  
directory. Move the pdftex.fmt file to ~/Library/texmf/web2c/ (you  
may have to build both the texmf and the web2c directories if they  
don't exist already). You may delete the pdftex.log file. Then both  
the original pdftricks and my modified package will start to work  

Once a general fix is announced remove that fmt file or any changes  
in that format or configuration (rare these days) will not be reflected.

I did notice that the lines for creating pdftex.fmt in fmtutil.cnf  
didn't have the -ini option for pdfetex.

Good Luck,

Herb Schulz
(herbs at wideopenwest.com)

------------------------- Info --------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
          & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/

More information about the MacOSX-TeX mailing list