[OS X TeX] terminal and tex4ht

Thomas Rike tricycle222 at earthlink.net
Mon Apr 17 15:24:37 EDT 2006

On Apr 17, 2006, at 11:27 AM, Herbert Schulz wrote:

> On Apr 17, 2006, at 1:15 PM, Thomas Rike wrote:
>> I am very inexperienced at the terminal and not very clear where  
>> things reside on my MacBookPro.  I was trying to get  
>> SimpleTex4ht.app to work, but it said tex4ht was not installed. I  
>> could see it in a folder but don't know what it takes to "install"  
>> it, so I went to the i-installer and in the "expert" mode  
>> installed tex4ht with no problems noted. However tex4ht "path to  
>> tex file" gives -bash: tex4ht: command not found.
>> ls /usr/local/teTeX/share/texmf.local
>> bibtex          dvips           metapost        tex
>> context         fonts           scripts         tex4ht
>> doc             ls-R            source          web2c
>>  I tried sudo texhash  ( I don't know what it does, but I hoped it  
>> would find/do something)  I typed my password and I got
>>   sudo: texhash: command not found
>> Now I am getting scared. TeXShop still works, so it understands  
>> where things are, but I don't know what has changed.
>> On my G4 all of these commands work with an installation from over  
>> a year ago. When I got the MacBookPro I installed TeX and the  
>> MacTeX.dmg and TeXShop which work fine. I did install the fink  
>> installer yesterday and I know that played around in the terminal  
>> for a long time. Hopefully that is not my problem. I really don't  
>> know what I am doing there. I'm just trying to learn
>> Any help would be appreciated. By the way, it doesn't look like  
>> any math or formatting is converted in the html document (on my  
>> G4). Is that to be expected? Thanks.
>> Tom Rike
> Howdy,
> This sounds like the Command Line Interface (CLI) wasn't installed  
> when you installed the system. Open up the TeX i-package with i- 
> Installer and run the C Configuration stage again making sure the  
> CLI setup is made. That sets up the correct paths for bash.
> Good Luck,
> Herb Schulz
> (herbs at wideopenwest.com)
Hi Herb,

Thanks for the speedy reply. I went back and ran Configure again and  
made sure that CLI was selected. No problems, but the terminal still  
does not recognize  sudo texhash  and I still get the same response  
when trying to use tex4ht

~ trike$ tex4ht /Users/trike/Desktop/test1.dvi
-bash: tex4ht: command not found

Anything else I can try in the terminal to see what pathnames are  
set? Thanks

Tom Rike

------------------------- Info --------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
          & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/

More information about the MacOSX-TeX mailing list