[OS X TeX] Re: apalike bib style

John B. Thoo jthoo at yccd.edu
Fri Aug 18 11:41:47 EDT 2006

I apologize for the long length of this post.

Written on Aug 17, 2006, at 5:00 PM, in MacOSX-TeX Digest #1824:

> Subject: Re: [OS X TeX] Re: apalike bib style
> From: "Alan Litchfield" <alan at alphabyte.co.nz>
> Date: Thu, 17 Aug 2006 15:38:14 +1200
> OK. That's odd and I have never seen that before with apalike or
> apacite. Could you send one or two of the entries from the bib file?

   AUTHOR = "Burton, D.\ M.",
   TITLE = "The History of Mathematics: An Introduction",
   EDITION = "5th",
   PUBLISHER = "McGraw-Hill",
   YEAR = 2003,
   ADDRESS = {Boston}

   AUTHOR = "Fine, H.\ B.",
   TITLE = "College Algebra",
   PUBLISHER = "Dover Publications, Inc.",
   YEAR = 1961,
   ADDRESS = {New York}

> I think you might get better results from apacite anyway. I have
> found it conforms to 5th better than apalike,  although John's
> suggestion of apa.cls looks interesting (I have never tried it).
> IIRC apalike is obsolete.

OK.  Apparently I don't have apacite, so I downloaded


and put all the files in the same folder as the LaTeX files.

(On a tangent, where should I put these files if I want them generally 
available, but don't want them to get clobbered if I update my tetex 
installation using Fink?)

Then I put in my LaTeX file


But when I latex the file using OzTeX, I get this error:

This is TeX, Version 3.14159 (no format preloaded)
**&LaTeX numrealrootscubic.tex
LaTeX2e <1999/06/01> patch level 1
Document Class: article 2001/04/21 v1.4e Standard LaTeX document class
(/sw/share/texmf/tex/latex/base/size10.clo)) (apacite.sty
Runaway argument?
! Paragraph ended before \ExecuteOptions was complete.
<to be read again>


Pressing Return repeatedly gives more errors, until I get this:

! LaTeX Error: Lonely \item--perhaps a missing list environment.

See the LaTeX manual or LaTeX Companion for explanation.
Type  H <return>  for immediate help.

l.24 ...man and White, 1998]{kalman-white}

) [6] [7] (numrealrootscubic.aux) )
Output written on numrealrootscubic.dvi (7 pages, 14236 bytes).
Transcript written on numrealrootscubic.log.

Memory allocated: 2173638 bytes.
Time elapsed: 117.3 seconds.

Then I run BibTeX without problems:

Calling Unix command: bibtex numrealrootscubic
Current directory: /Users/jbthoo/Desktop/CardanoFormulaApa

This is BibTeX, Version 0.99c (Web2C 7.4.5)
The top-level auxiliary file: numrealrootscubic.aux
I found no \bibstyle command---while reading file numrealrootscubic.aux
(There was 1 error message)

Then I latex the file a couple more times, getting the same errors as 
before.  But when I open the resulting .dvi file, Page 1 reads

   Unpublished master's thesis

   Language definition file .apc not found.

I'm at a loss.

> Note that there is already an apa.cls in the standard LaTeX
> distribution. I don't know how that relates to this other one. They
> may be the same thing, or they may be different and the author has
> unfortunately used the same name as an existing class file.
> Cheers
> Alan

I did not have any better luck with apa.cls, using


I wish I knew my way around (La)TeX more.

Thanks for all your help thus far.


> On Aug 17, 2006, at 3:13 PM, John B. Thoo wrote:
>> Hi, Alan.  Two things appear differently.
>> 1. In the References, it lists items as, e.g.,
>>    [Burton, 2003] Burton, E. M. (2003).  The History....
>> instead of just
>>    Burton, E. M. (2003).  The History....
>> 2. When I use \cite{burton}, e.g., it outputs
>>    [Burton, 2003]
>> instead of using round brackets
>>    (Burton, 2003).
>> Also, when I use \cite{burton, fine}, e.g., it outputs
>>    [Burton, 2003, Fine 1961]
>> instead of using a semicolon
>>    (Burton, 2003; Fine 1961).
>> Cheers,
>> ---John.
"There are no atheists in foxholes."
---Fr. William T. Cummings, M.M. (WWII, Philippines)
[_The Grunt Padre_, CMJ Marian Pub., p. 56]

------------------------- Info --------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
          & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/

More information about the MacOSX-TeX mailing list