[OS X TeX] preview-latex altering value of %t in latex command template

Christopher Menzel cmenzel at tamu.edu
Wed Dec 20 15:12:52 EST 2006

Not sure if this is an Aquamacs Emacs problem but thought I'd try  
here first.  Currently, C-c C-c (or C-c C-b) runs latex by (as usual)  
drawing on the latex command template in my auctex configuration (in  
the Emacs customization options).  That template uses a %t variable  
to pick up the name of my current document -- say "myfile.tex".  This  
works fine until I run preview-latex.  Upon doing so, then next time  
I run LaTeX with C-c C-c, the command runs on the filename "_region_"  
instead of the name of my actual document "myfile".  Since the output  
of this is a file called _region_.pdf, my previewer in turn does not  
update -- since of course it is displaying myfile.pdf and watching  
*it*, not _region_.pdf, for changes.  Does anyone have any idea  
what's happening here and how to fix it?  If it's a preview-latex  
bug, I'll report it to the bug-auctex list.

Much obliged.

Chris Menzel

------------------------- Helpful Info -------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/
List Reminders & Etiquette: http://www.esm.psu.edu/mac-tex/list/

More information about the MacOSX-TeX mailing list