[OS X TeX] Re: Installing Fonts for LaTeX on OSX

Bruno Voisin bvoisin at mac.com
Tue Jul 4 12:19:42 EDT 2006

Le 30 juin 06 à 15:45, Dennis Kletzing a écrit :

> I wrote to Bob Kerstetter about the article Installing Fonts for  
> LaTeX on OS X and he mentioned that you were the person who  
> actually did most of the technical work for the article.
> I found this article at the TUG Web Site.  It's an excellent source  
> for helping me get new fonts installed and I appreciate the time  
> you spent preparing it. But I ran into a problem that I'm hoping  
> you can help me with.

Thanks for the nice words. Sorry for the late answer, I was away last  
week and I'm now still catching up with the accumulated mail.

Unfortunately I no longer have the time to look at font issues in TeX  
on OS X. When I wrote the article (originally as a post to this  
list), I made it clear it was a one-shot thing, and that I wouldn't  
be able to update it. I was hoping it would set the basis for a  
community effort, and that others would take charge, enriching,  
maintaining and updating the article as needed. Unfortunately that  
didn't happen. In its current state the article is substantially  
outdated [see below for a possible diagnosis of your problem], but  
presently there's nothing I can do about it. Sorry.

For up-to-date information please contact the OS X TeX list (to which  
this message is cc'ed): there you'll find all the experts, able and  
willing to help. But please don't contact me personally, unless that  
really can't be avoided. As it happens, I'm willing to devote less  
and less time to TeX-related matters. I've not really been successful  
in that respect this far, but that remains one of my top-priority goals.

> I've been a Textures user for many years and have waited patiently  
> for the OS X version to appear. When the alpha version finally was  
> posted, I was discouraged by how crude it is, so I downloaded the  
> TeXShop programs and decided to give this a try. That's when I ran  
> into font problems. Everything is done in the unix way, which is  
> completely foreign to me. I found the article on the TUG Web Site  
> and found it very helpful.
> As a test, I tried making some basic Frutiger fonts to use in  
> TeXShop. I created a folder and put all of the fontinst things in  
> it and the Frutiger afm files. Everything went ok as I worked  
> through your article, all of the various files were generated,  
> the .pl, .vpl, and .tfm, files, etc. Finally, I created the map  
> file, which I called frutiger.map, also in the same folder. When I  
> now run TeXShop with the line \fontfamily{fxm}\selectfont, nothing  
> happens. It complies the file, but complains about not finding the  
> fxmr8r file. I don't know why, because I see the file in the folder.
> You mention that a safe way to proceed is to install things in the  
> home folder and check to see if everything works ok before moving  
> them. So I haven't tried to move things into all the different  
> places until I'm sure that things work ok.
> I'm not sure if it will help, but here is the log file that came  
> out of the compiling:
> ----------
> This is pdfeTeX, Version 3.141592-1.30.4-2.2 (Web2C 7.5.5)
> [...]
> (./fontinsttest.aux) (./ot1fxm.fd) [1{/usr/local/teTeX/share/ 
> texmf.local/fonts/
> map/pdftex/updmap/pdftex.map}] (./fontinsttest.aux)kpathsea:  
> Running mktexpk --mfmode / --bdpi 600 --mag 1+0/600 --dpi 600 fxmr8r
> mktexpk: don't know how to create bitmap font for fxmr8r.
> kpathsea: Appending font creation commands to missfont.log.
> )
> Warning: /usr/local/teTeX/bin/powerpc-apple-darwin-current/pdflatex  
> (file fxmr8
> r): Font fxmr8r at 600 not found
> </usr/local/teTeX/share/texmf.tetex/fonts/type1/bluesky/cm/cmr10.pfb>
> [...]
> ----------
> I'm not sure if my problem is a missing file or if TeXShop is  
> looking for a file in a certain place and not finding it. Any  
> suggestions you can give me would be greatly appreciated. Many thanks.

According to the info you provide, I suspect you omitted a crucial  
step: after generating the various .tfm, .vf, .pfb,  .fd and .map  
files, put them at the appropriate places then run updmap.

Regarding this step, the article is obsolete in two respects, owing  
to recent changes in TeXLive and teTeX (upon which gwTeX, i.e. the  
TeX i-Package, is based):

- .map files should go inside ~/Library/texmf/fonts/map/dvips/  
instead of ~/Library/texmf/fonts/dvips/

- updmap should be run as "sudo updmap-sys --enable Map frutiger.map"  
instead of "sudo updmap --enable Map frutiger.map"

In case you have files at the following locations, it would also be  
advisable to delete them beforehand (taken from a post by Gerben  

> 	~/Library/texmf/tex/generic/config/language.dat
> 	~/Library/texmf/fonts/map/dvipdfm/updmap/dvipdfm.map
> 	~/Library/texmf/fonts/map/dvipdfm/updmap/dvipdfm_dl14.map
> 	~/Library/texmf/fonts/map/dvipdfm/updmap/dvipdfm_ndl14.map
> 	~/Library/texmf/fonts/map/dvips/updmap/builtin35.map
> 	~/Library/texmf/fonts/map/dvips/updmap/download35.map
> 	~/Library/texmf/fonts/map/dvips/updmap/ps2pk.map
> 	~/Library/texmf/fonts/map/dvips/updmap/psfonts.map
> 	~/Library/texmf/fonts/map/dvips/updmap/psfonts_pk.map
> 	~/Library/texmf/fonts/map/dvips/updmap/psfonts_t1.map
> 	~/Library/texmf/fonts/map/pdftex/updmap/pdftex.map
> 	~/Library/texmf/fonts/map/pdftex/updmap/pdftex_dl14.map
> 	~/Library/texmf/fonts/map/pdftex/updmap/pdftex_ndl14.map
> 	~/Library/texmf/web2c/updmap.cfg
> 	~/Library/texmf/web2c/fmtutil.cnf
> 	~/Library/texmf/web2c/*.log
> 	~/Library/texmf/web2c/*.fmt
> The last line you have to be careful with in case you created your  
> own unique formats and dumped them there, as they also end in .fmt.  
> You should remove only those that already exist in /usr/local/teTeX/ 
> share/texmf.local/web2c

I don't have time to elaborate on the details re. updmap-sys vs.  
updmap; see the OS X TeX list archive where this issue has been  
creating havoc for about a year now. There are several alternatives;  
the above solution is not necessarily the better, but at least it  
should work.

That said, given your .log file refers to /usr/local/teTeX/share/ 
texmf.local/fonts/map/pdftex/updmap/pdftex.map, I think the problem  
is not related to updmap-sys vs. updmap, but simply to the fact that  
either you haven't been running updmap at all, or that you haven't  
put frutiger.map at the appropriate place (namely one where updmap(- 
sys) sees it) first.

Hope this helps,

Bruno Voisin------------------------- Info --------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
          & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/

More information about the MacOSX-TeX mailing list