[OS X TeX] Handling EPS files

Josep M. Font jmfont at inicia.es
Wed Mar 15 12:26:43 EST 2006


Encouraged by what I learned in the recent thread "Timing problem  
resolved" I tried to process a file that includes several EPS files,  
and which up to now I had (successfully) processed with the TeX +  
dvips + GhostScript way. I wanted to convert the EPS files to PDF  
files. The experience has lead me to several questions.

1) When I did (in the terminal)

apply pstopdf *.eps

I got the corresponding PDF files and then I could use (successfully)  
the pdfTeX way. However, I had previously tried to do

apply epstopdf *.eps

and I got a "permission denied" reply; more precisely, I got a line:

Permission denied.

for each of the EPS files to process. Usign sudo did not solve this.

Does this make any sense ? Is this to be expected ? Is there  
something wrong with my installation or configuration ? I use MacOSX  
10.4.5, TeXShop 2.09a, and the gwTeX installation is fairly recent as  

2) A maybe related problem was that I first tried to do this  
conversion "on the fly" by putting \usepackage{epstopdf} in the file  
and then processing it with TeX + dvips + GhostScript: the file was  
typeset, but the PDF files were not produced, and no error message  

3) It was not clear to me from the thread how the "on the fly"  
conversion has to be performed (once, as advised): with TeX + dvips +  
GhostScript or with pdfTeX ? I conjecture the former...

Any light on all this will be appreciated.


------------------------- Info --------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
          & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/

More information about the MacOSX-TeX mailing list