[OS X TeX] include cannot be nested?

Alain Schremmer Schremmer.Alain at gmail.com
Sat Nov 4 16:43:44 EST 2006

Being both terminally curious and terminally obstinate, I cannot leave 
well enough alone and sometimes it gets to be expensive. Here is the 
latest case in point with TeXShop 1.43 on 10.3.9 (I am waiting for the 
dust to settle before I upgrade :-) )

1) I have a Bookfile with a number of included Chapter/n.
Each Chapter/n has an included ExerciseSet/n.
As I recall, things worked beautifully. But:

2) Then I created HomeWork/n files that include Exercise/n so as to be 
able to typeset and hand-out ExerciseSet/n as Homework/n. That works 
very nicely.

3) Then I added on top of each ExerciseSet/n the line
%!TEX root = ../HomeWork/n.tex
to make it easier to check the source of ExerciseSet/n as I wrote. That 
works very nicely.

4) Then, in Bookfile, I added a renewcommand (designed by this list) so 
that instead of including the exercises in each chapter whenever I 
typeset the whole book (circa 300 pages right now without the 
Exercise/n), I could just have the url to make the compile time shorter 
and this is what I have been doing for several months now.

However, when I tried yesterday to switch and look at the Magnum Opus in 
its full glory, complete with Exercises, I got various error messages, 
from "can't find the file" to "can't write on the aux". I wasn't too 
surprised since I had reorganized several times the by now some 14,000 
files I am using—a lot are the graphics and their pdf but this has also 
to do with the fact that the Magnum Opus has to serve in several 
different guises.

I have now spent a whole day trying to understand file paths up and down 
folders and I think that I finally got to understand how LaTeX works but 
now I am getting a message saying "include cannot be nested". Since I 
would of course swear on anything that it used to, I am now terminally 
stuck as I don't know what it really means and what to do.

So, I would truly appreciate whatever help.

(However, note that none of the above is a disaster since I have not 
lost anything other than the ease of switching among different versions.)

Hopeful regards

P.S. By the way, as I was trying carious paths in various situations, I 
would often get a blank pdf with "Page -2147 of 1" which is something I 
had never had before. Once that happened, nothing would do, even getting 
rid of the aux and even the pdf itself. I had to quit TeXShop. I think 
that I can reproduce it but I don't think it's worth troubling anyone. 
Just a curiosity.
------------------------- Info --------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
          & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/

More information about the MacOSX-TeX mailing list