[OS X TeX] Problem compiling with XeLaTeX

John Rawnsley j.rawnsley at warwick.ac.uk
Thu Nov 23 04:10:54 EST 2006

On 23 Nov 2006, at 05:19, S P Suresh wrote:

> I just reinstalled the TeXLive i-Package after the latest update by  
> Gerben. I am running Mac OS X 10.4.8 on an iBook G$ (PowerPC). When  
> I try to compile a document with xelatex I get the error message  
> that xelatex.fmt is not found.

This happened to me also.

When you installed the TeXLive i-package originally on a PPC machine
xetex was not available so the xelatex format was not built. The
list of formats to be built seems to be saved between runs of
i-Installer so when you installed the updated package the
format xelatex was still not built. Run i-Installer on the package
again in Configure Only mode, do an expert run and choose to select
formats and build formats. When asked to select formats, scroll to
the bottom of the list of formats and make sure the boxes for the
xetex formats are checked. It worked for me.

> Here is the exact output.
> This is XeTeX, Version 3.141592-2.2-0.995 (Web2C 7.5.5)
> kpathsea: Running mktexfmt xelatex.fmt
> fmtutil: format directory `/usr/local/TeXLive/texmf.local/web2c' is  
> not writable.
> I can't find the format file `xelatex.fmt'!
> What is this about the directory not being writable? Have I done  
> anything stupid? Please enlighten me on this.

This is because the TeXLive directories need root privileges
to write to them. When you run i-Installer it asks for an
administrator password so it can save the formats in this
directory, but when you run commands as a user you don't
have enough privileges.

Hope that helps,

  John Rawnsley * <http://go.warwick.ac.uk/jhrawnsley>

------------------------- Info --------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
          & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/

More information about the MacOSX-TeX mailing list