[OS X TeX]

Paul Fontana fontanap at seattleu.edu
Fri Sep 8 20:36:29 EDT 2006

>> I still have not gotten your script to work (I get 'Permissions  
>> denied')
> I mentioned that: executable! Either 'chmod 755 <your script>' or  
> 'chmod a+x your script>' or with Finder's inspector.

No, I tried that.  That's how I got 'Permissions denied' instead of  
'command not found'.  But this is more of a Mac-Unix question, and so  

>> but after studying it I think I get what it does and have reproduced  
>> some of it manually.  Interestingly, it seems to typeset correctly  
>> when I use pdflatex from the command line, but when I do exactly the  
>> same thing from TeXShop it doesn't work.
> Because TeXShop does not accept any input?

On the contrary -- you just give the input at the command line of the  
TeXShop console for the file you're LaTeXing.  It works almost exactly  
the same way as in the terminal, except with a command line instead of  
continuous scroll (assuming you are using nfssfont interactively at the  
terminal).  Anyway, the font works in both environments now (except  
with different engines), so this point is moot.

> Am 08.09.2006 um 22:03 schrieb Paul Fontana:
>> I get a slightly nicer-looking version than if I do the whole thing  
>> (processing and rendering) in TeXShop.  The two .pdf's also look a  
>> little different in Preview, though less-so (the pdflatex document is  
>> lighter in weight), but I can't tell the difference between them when  
>> I print.  (It also makes a slight difference whether TeXShop is set  
>> to typeset in 'Pdftex' or in 'Tex and Ghostscript'.  Does this point  
>> to different distillers?)
> Don't guess! Read the LOG files. They explain which fonts are used.

OK, here are excerpts from the files:
TeXShop (i-installer?) version:
<-- snip -->
<-- snip -->

Terminal (Fink?) version:
<-- snip -->
<-- snip -->

So one is using fonts/pk/modeless/adobe/kaufmann/pkur8r.600pk, and the  
other is using fonts/type1/adobe/kaufmann/pkur8a.pfb.  What's the  
difference?  (As I said, I can't see any difference at the printer --  
only in TeXShop or Preview.).  I guess the two versions of pdftex.map  
must be different for some reason, probably due to the convoluted  
process of installing the font.

As for selecting one engine or the other, since I like the type1  
rendering better I have changed my configuration settings to:
(pdf)TeX:  /sw/bin/  (was:   
TeX + dvips + distiller:
Tex program:  altpdftex  (was:  simpdf tex --maxpfb *or*   
/usr/local/teTeX/bin/powerpc-apple-darwin-current/simpdf tex --maxpfb)
Latex program:  aldpdflatex  (was:  simpdf latex --maxpfb  *or*   
/usr/local/teTeX/bin/powerpc-apple-darwin-current/simpdf latex  

because these look the best on the screen.  As for anything more  
complete, considering my limited skills I think I'm willing to allow  
peaceful coexistence.  I'm afraid to change the configuration now that  
everything is working.  Someday when I have a few days with nothing  
better to do maybe I will take a chance and opt for surgery.  (The  
margins seem to be a little different when I run nfssfont -- hopefully  
they will be OK when I process my old files with the new setup!)

Thanks, Peter and Herbert, for all your help on this one!  I have  
certainly learned a great deal in the process.
-- pwf

------------------------- Info --------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
          & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/

More information about the MacOSX-TeX mailing list