[OS X TeX] TeXShop and Lilypond

Alan Munn amunn at msu.edu
Tue Apr 17 11:28:17 EDT 2007

At 9:54 AM -0500 4/17/07, Michael Millett wrote:
>I ran this from the Terminal after cd'ing my way to the correct directory:
>    chmod 755 Lilypond-LaTeX.engine
>Then, I changed the first line of my TeXShop file from:
>%%!TEX TS-program =Lilypond-LaTeX

This should work.  Did you get the same error as before  when you had 
this as the first line?  I recall the error was

2007-04-16 23:00:45.407 TeXShop[327] *** NSTask: Task create for path 
/Users/michaelm/Library/TeXShop/Engines/Lilypond-LaTeX.engine failed: 
2, "No such file or directory".

Did you delete the folder of associated aux files?

In a terminal window, what does the following return?

ls -l /Applications/Lilypond.app

>    %%!TEX TS-program = ~/Library/TeXShop/engines/Lilypond-LaTeX

This won't work at all. (As the messages below show!)

>And this time I got past the "no such file or directory" error, and 
>got this error:
>! LaTeX Error: Environment Lilypond undefined.

Alan Munn 
amunn at msu.edu
Department of Linguistics                             
and Germanic, Slavic, Asian and African Languages   Fax.  +1-517-432-2736
Michigan State University, East Lansing MI 48824       Tel.  +1-517-355-7491

------------------------- Helpful Info -------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/
List Reminders & Etiquette: http://www.esm.psu.edu/mac-tex/list/

More information about the MacOSX-TeX mailing list