[OS X TeX] Problem when reinstalling MathTimePro fonts in TeXLive

André Bellaïche abellaic at math.jussieu.fr
Tue Feb 13 15:25:27 EST 2007

Le 13 févr. 07 à 10:45, Bruno Voisin a écrit :

> Le 13 févr. 07 à 10:11, André Bellaïche a écrit :
>> Second, when I ran it this morning, I got
>> sudo -H updmap-sys --enable Map mtpro2.map
>> Password:
>> updmap: This is updmap, version 1167072206
>> updmap: using transcript file `/usr/local/texlive/2007/texmf-var/ 
>> web2c/updmap.log'
>> updmap: initial config file is `/usr/local/texlive/2007/texmf- 
>> config/web2c/updmap.cfg'
>> updmap: configuration (updmap.cfg) unchanged. Map files will not  
>> be recreated.
> Can you check several things:
> - Does /usr/local/texlive/2007/texmf-config/web2c/updmap.cfg  
> contain the line:
> 	Map mtpro2.map
> I think it does.

Yes. It is the last line of the file.
> - Do
> 	/usr/local/texlive/2007/texmf-var/fonts/map/dvips/updmap/psfonts.map
> 	/usr/local/texlive/2007/texmf-var/fonts/map/pdftex/updmap/pdftex.map
> 	/usr/local/texlive/2007/texmf-var/fonts/map/dvipdfm/updmap/ 
> dvipdfm.map
> 	/usr/local/texlive/2007/texmf-var/fonts/map/dvips/updmap/ps2pk.map
> contain the content of mtpro2.map (in a slightly different form for  
> the third)?

The 1st one is an alias to psfonts_t1.map and does not contain any  
mention of mt2
The 2nd one is an alias to pdftex_dl14.map and does not contain any  
mention of mt2
The 3rd one is an alias to dvipdfm_dl14.map and does not contain any  
mention of mt2
The 4th one is not an alias and does not contain any mention of mt2

> - Do you have unwanted config files inside ~/Library/texmf, namely:
> 	~/Library/texmf/tex/generic/config/language.dat
> 	~/Library/texmf/fonts/map/dvipdfm/updmap/dvipdfm.map
> 	~/Library/texmf/fonts/map/dvipdfm/updmap/dvipdfm_dl14.map
> 	~/Library/texmf/fonts/map/dvipdfm/updmap/dvipdfm_ndl14.map
> 	~/Library/texmf/fonts/map/dvips/updmap/builtin35.map
> 	~/Library/texmf/fonts/map/dvips/updmap/download35.map
> 	~/Library/texmf/fonts/map/dvips/updmap/ps2pk.map
> 	~/Library/texmf/fonts/map/dvips/updmap/psfonts.map
> 	~/Library/texmf/fonts/map/dvips/updmap/psfonts_pk.map
> 	~/Library/texmf/fonts/map/dvips/updmap/psfonts_t1.map
> 	~/Library/texmf/fonts/map/pdftex/updmap/pdftex.map
> 	~/Library/texmf/fonts/map/pdftex/updmap/pdftex_dl14.map
> 	~/Library/texmf/fonts/map/pdftex/updmap/pdftex_ndl14.map
> 	~/Library/texmf/web2c/updmap.cfg
> 	~/Library/texmf/web2c/fmtutil.cnf
> 	~/Library/texmf/web2c/*.log
> 	~/Library/texmf/web2c/*.fmt
> I think you don't, but if you do, erase them and try the following.

I have no ~/Library/texmf directory. I tried to ls from the TerminaI,  
and also by the classical Mac way, looking at the  <myaccount>/ 

> In any case, what you may try is:
> 	sudo -H updmap-sys --nohash --nomkmap --disable mtpro2.map
> 	sudo -H updmap-sys --enable Map mtpro2.map
> The first instruction will remove the mtpro2.map entry from  
> updmap.cfg, and the second will restore it then update psfonts.map,  
> pdftex.map, dvipdfm.map and ps2pk.map accordingly. Without the  
> first instruction, updmap notices updmap.cfg hasn't changed and  
> refuses to update psfonts.map etc.; this is what happened in your  
> case.
> Hopr this works,

It works !

Thank you for all your work,

------------------------- Helpful Info -------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/
List Reminders & Etiquette: http://www.esm.psu.edu/mac-tex/list/

More information about the MacOSX-TeX mailing list