[OS X TeX] Problems with permissions using i-Installer

Gerben Wierda Gerben.Wierda at rna.nl
Thu Jan 4 11:16:06 EST 2007

On Jan 4, 2007, at 16:52 , Martin Buchmann wrote:

> Hi :-)
> I haven't been subscribed to this list for while so first I want to  
> say hello again to everybody.
> I have some problems with the new gwTeX I installed on my system  
> (ppc/10.4.8) a few days before. As far as I can tell there is  
> something screwed up with the permissions and the linking from /usr/ 
> texbin to the actual binaries.
> I tried to re-created the links according to the structure  
> described in /Library/TeX/Distributions/TeXDist-description.rtf but  
> it is quite some work and not really working. The whole concept is  
> still very new to me and leaves me with some problems: If I try to  
> invoke latex from the command line I get
> /usr/local/gwTeX/bin/powerpc-apple-darwin7.9.0/latex: Permission  
> denied
>> metallw08:/usr/local/gwTeX/bin/powerpc-apple-darwin7.9.0 Martin$  
>> ll latex
>> ls: latex: Permission denied
>> lrwxr-x---   1 root  staff  7  4 Jan 15:57 latex@
> I have /usr/texbin in my path:
> lrwxr-xr-x     1 root    wheel      66  4 Jan 16:09 texbin@ -> ../ 
> Library/TeX/Distributions/.DefaultTeX/Contents/Programs/powerpc
> before this link was broken too because of the wrong permissions. I  
> deleted it and recreated it using ln -s. I tried to change the  
> permissions using 'sudo chmod' but this did work on links even with  
> the '-L -R' options. I guess I am missing some basic Unix-knowledge  
> here :-(
> Basically, my problem comes down to two parts:
> 1.) How can i fix the broken links easily, and
> 2.) Why is i-Installer not able to set things up correctly in the  
> first place? Re-installing/configuring isn't working. So I'm lost  
> without a working TeX after all the years i-Installer was doing so  
> well :-(

Your problem is not with the links but it is with the permissions of  
the unarchived files. Maybe you have set a different umask in your  
GUI-app environment or maybe some permission was inherited (this may  
differ between different versions of Mac OS X) trough the file  
system. In any case, what you are experiencing is not a standard  

On my system:

lrwxr-xr-x   1 root  staff  7 Jan  4 14:58 /usr/texbin/latex -> pdfetex

shows that latex symlink has world read-execute permisisons. But on  
your system it has not.

What you could try is to set i-Installer's preferences to override  
the environment (this will be the default in the next version) and  


------------------------- Helpful Info -------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/
List Reminders & Etiquette: http://www.esm.psu.edu/mac-tex/list/

More information about the MacOSX-TeX mailing list