[OS X TeX] LaTeX with TextMate

Charilaos Skiadas skiadas at hanover.edu
Sun Jan 21 19:51:12 EST 2007

On Jan 21, 2007, at 7:31 PM, Adam R. Maxwell wrote:

> On Jan 21, 2007, at 15:58, Charilaos Skiadas wrote:
>> On Jan 21, 2007, at 5:41 PM, Michael S. Hanson wrote:
>>> 	2. How do I get the window that pops up when compiling (like the  
>>> "Console" in TeXShop) to reappear so that I can actually read the  
>>> warnings that go whizzing by?
>> In the Help inside the LaTeX bundle, look at section "3.4 Preview  
>> Options".
> And you access that Help via the action menu at the bottom of  
> TextMate's window, in the LaTeX submenu, right?  I occasionally  
> forget about that when searching the application's Help.

Yes, or via the menus on top under Bundles -> LaTeX -> Help (those  
are the same menus).
Or, while in a LaTeX file, you can type shift-cmd-T, and then type  
"help" and select the appropriate option. (Help -LaTex).

>>> 	3. Autocompletion does not appear to work for me.  If I type in  
>>> some characters (say, the start of a common LaTeX command) and  
>>> press [Escape], all I get it a "beep" and nothing else.
>> Which command was that? TextMate knows about a bunch of commands,  
>> for instance typing "\f" and then pressing escape over here cycles  
>> among \flat, \forall and \frac. But perhaps we have missed some  
>> commands.
>> Also, in general it is better to generate commands via the "cmd+}"  
>> combo (that's "cmd+shift+]" in US keyboards). For instance typing  
>> "sub" and pressing the cmd+} combo creates a subsection. You can  
>> set all these shortcuts up via the "Edit Configuration File" command.
> I just tried this (type "sub", hit cmd-shift-], in a newly created  
> document via the default LaTeX template.  I get
> /Library/Application Support/TextMate/Bundles/Latex.tmbundle/ 
> Support/lib/config_helper.rb:18:in /bin/bash: expand_path: couldnt:  
> command not found~/Library/Preferences/ 
> com.macromates.textmate.latex_config.plist' (ArgumentError)
>     from /Library/Application Support/TextMate/Bundles/ 
> Latex.tmbundle/Support/lib/config_helper.rb:18:in /bin/bash: -c:  
> line 0: unexpected EOF while looking for matching `''
> /bin/bash: -c: line 2: syntax error: unexpected end of fileload'
>     from /tmp/temp_textmate.uH8iTJ:3

Hm, this is really weird, it seems to have problems with the  
following ruby line:
Try to copy and paste this line into a new document, and type ctrl- 
shift-E. This line should be executed in Ruby and give you a path as  
output, in my case it says:
Do you by any chance have any local modifications under ~/Library/ 
Application Support/TextMate?

What about the cmd-shift-{ one (that's the one creating  
environments)? Type any shortcut, it should work. In fact, it should  
work even without a shortcut. Let's see if we get the same error.  
(Perhaps we can take it off-list from that point on)
> thanks,
> Adam


------------------------- Helpful Info -------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/
List Reminders & Etiquette: http://www.esm.psu.edu/mac-tex/list/

More information about the MacOSX-TeX mailing list