[carbon-emacs:179] Re: [OS X TeX] Re: PDFViewer

Roussanka Loukanova rloukano at stp.lingfil.uu.se
Thu May 17 13:17:13 EDT 2007

Hi again,

On Thu, 17 May 2007, Roussanka Loukanova wrote:
> On Thu, 17 May 2007, David Reitter wrote:
>> On 16 May 2007, at 22:59, Roussanka Loukanova wrote:
>>> (defun raise-emacs-on-aqua()
>>>    (shell-command "osascript -e 'tell application \"Emacs\" to
>>> activate' &"))
>>> opens up an *Async Shell..." and adds robustness. I find the Async
>>> Shell
>> Does Carbon Emacs not have the `do-applescript' function?
>> I don't quite see why one need to ask the shell to ask osascript to
>> execute a script when you can execute the script directly. That
>> should address the Async buffer business.
> If somebody could tell how, it would be good, because it creates problems
> at least for those of us who've tried to use pdfview from Carbon Emacs. (I
> myself do not know these script languages.)

I took off the suspicious shell-command, and left in .emacs this:


+ the code for forward search.

It seems working, but I do not know the full capacity of PDFView. For 
ex.: When typesetting in emacs by modifying a location, which is not on 
the currently displayed pdf page, the update of the pdf happens, but 
PDFView doesn't jump to the corresponding pdf page. I do not know if this 
is implemented in PDFView or not. Indeed, PDFView takes me to the proper 
page of the pdf, if I issue C-c C-c to invoke explicitly the View 

Before that, I'd tried substituting do-applescript for osascript:

- with the ampersand it didn't pdfview and/or pdfsync didn't work;
- without the ampersand, I get:

/bin/bash: line 1: do-applescript: command not found


------------------------- Helpful Info -------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/
List Reminders & Etiquette: http://www.esm.psu.edu/mac-tex/list/

More information about the MacOSX-TeX mailing list