[OS X TeX] updating TeXLive and font maps?

Gary L. Gray gray at engr.psu.edu
Sun May 20 19:18:16 EDT 2007

On May 20, 2007, at 1:51 PM, Bruno Voisin wrote:

> Le 20 mai 07 à 18:07, Gary L. Gray a écrit :
>> [...]
>> This didn't look good, so Googling "Map files will not be  
>> recreated" led me to a post by Bruno from almost 5 years ago that  
>> said something about needing to disable the font mapping and then  
>> re-enabling it to fix this problem. So, I did:
>> loon:~ gray$ sudo updmap-sys --disable mtpro2.map
>> and then:
>> loon:~ gray$ sudo updmap-sys --enable Map mtpro2.map
>> and I was up and running again. Is this normally what needs to be  
>> done? I don't understand why I simply couldn't enable it and why I  
>> first needed to disable it.
> I never quite understood what happens here exactly. The problem is  
> that updmap both updates updmap.cfg (first), and then (afterwards)  
> recreates the appropriate map files psfonts.map etc. based on it.  
> Whatever is inside the map files, in cases updmap detects  
> updmap.cfg wouldn't be changed by enabling the requested map file  
> fragment (even if the actual map files do no longer correspond to  
> this updmap.cfg), it stops proceeding and refuses to go further.
> That's why, I think, Gerben uses flags to run updmap several times  
> in sequence, isolating each time a specific task, when running  
> updmap during installation of the gwTeX i-Package. Something like,  
> in your case:
> 	sudo updmap-sys --nohash --nomkmap --syncwithtrees
> 	sudo updmap-sys --nohash --nomkmap --disable mtpro2.map
> 	sudo updmap-sys --nohash --nomkmap --enable Map mtpro2.map
> 	sudo updmap-sys
> I'm not sure that, with the first "--syncwithtrees" step, it would  
> even be necessary to run the "--disable" step.

I tried Franck's suggestion and it worked, so I think I am set (for  
now). :-)

>> Now, for my **second** question. When enabling mtpro2, I get the  
>> following message in the Terminal output (there is actually a  
>> similar message for pmy.map):
>> updmap: using map file `/Users/gray/Library/texmf/fonts/map/dvips/ 
>> mtpro2/mtpro2.map'
>> !!! WARNING: Identical copy of used file for `mtpro2.map'
>>     exists in obsolete location
>>       /Users/gray/Library/texmf/dvips/mtpro2/mtpro2.map
>>     Please, consider removing this file.
>> Why is this happening? The only mtpro2.map file I have is in:
>> /Users/gray/Library/texmf/dvips/mtpro2/mtpro2.map
>> So why is updmap complaining about an identical file in an  
>> obsolete location?
> That's the actual location which is obsolete:
> /Users/gray/Library/texmf/dvips/mtpro2/mtpro2.map
> Map files must go inside ~/Library/texmf/fonts/map/ to be seen (and  
> the usual location is inside dvips/ within that directory).

Thank you Bruno. I now see that. :-) Somehow, when I installed Myriad  
and MathTimes Pro, I ended up with two map files.

All the best,

------------------------- Helpful Info -------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/
List Reminders & Etiquette: http://www.esm.psu.edu/mac-tex/list/

More information about the MacOSX-TeX mailing list