[OS X TeX] problems with Minion Pro package with gwTeX

Herbert Schulz herbs at wideopenwest.com
Wed May 30 20:00:33 EDT 2007

On May 30, 2007, at 5:58 PM, Ted Sider wrote:

> Hi all,
> Sorry if this question is too basic for this list.
> I'm using the gwTeX distribution for Mac OS X, and am having trouble
> getting the MinionPro package to work.  (I got it to work on one of  
> my machines a
> few months ago, and just tried and failed to install it on another,
> but can't figure out what the relevant difference is.  Though I just
> noticed that the version of MinionPro on the working machine is 2.0
> and that the version on the unworking one is 2.1)  I have all the
> MinionPro files in the right place in my local texmf tree, ~/Library/
> texmf.  As near as I can tell (though I'm no expert), the information
> for the MinionPro font isn't making its way into  	
> 	/usr/local/teTeX/share/texmf.local/fonts/map/pdftex/updmap/pdftex.map


Huh? What distribution are you using? How old is your TeX  
distribution? If it's really a recent gwTeX (based on TeX Live) the  
files should be starting at /usr/local/gwTeX/, not /usr/local/teTeX/ 

> (which, I gather, is created by updmap.)   This file (...  
> pdftex.map) has many lines about Minion Pro on the machine where  
> things are working, and it has nothing about Minion Pro on the  
> machine where things are not working.  I'm pretty sure the files  
> are all in the right places; and I did:
> 	sudo texhash
> 	sudo updmap --enable Map MinionPro.map
> (I also did  sudo -H -u root updmap-sys --enable Map MinionPro.map  
> as suggested at http://ii2.sourceforge.net/tex-index.html.)
> I tried copying all the files from ~/Library/texmf to /usr/local/ 
> teTeX/share/texmf.local, and that didn't work either.

Also, in the latest gwTeX you should be placing local additions to  
the system into the texmf.pkgs tree rather than texmf.local.  
Depending upon how you set up your system updamp MAY be the same as  
updmap-sys but using `sudo -H -u root ...` will miss anything in your  
personal tree at ~/Library/texmf/... .

> At any rate, that's where I'm stuck.  I'm guessing the problem has  
> something to do with the multiple texmf trees of gwTeX, and map  
> information going in the wrong place?  At any rate, any help would  
> be most appreciated!  (In case this is not enough information, I'm  
> pasting in below the full output from LaTeX console, from a failed  
> attempt to typset using MinionPro.sty, as well as part of the .log  
> file from that same attempt.)
> Thanks, and sorry again to bother.
> Ted Sider
> Professor of Philosophy
> Rutgers University

Where, exactly did you put the files?

Good Luck,

Herb Schulz
(herbs at wideopenwest.com)

------------------------- Helpful Info -------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/
List Reminders & Etiquette: http://www.esm.psu.edu/mac-tex/list/

More information about the MacOSX-TeX mailing list