[OS X TeX] problems with Minion Pro package with gwTeX

Ted Sider sider at philosophy.rutgers.edu
Thu May 31 14:50:40 EDT 2007

On May 31, 2007, at 7:05 AM, Peter Dyballa wrote:

> Am 31.05.2007 um 10:15 schrieb Bruno Voisin:
>> Actually, if I'm not mistaken, upon install gwTeX makes updmap  
>> synonymous to updmap-sys.
> Bruno, you *are* mistaken here: both scripts are different! Updmap- 
> TEXMFSYSCONFIG. Then updmap is called to do the real job on the  
> basis of these two variables set. The difference is that the output  
> of updmap-sys lands in a set of system-wide directories (/usr/local/ 
> gwTeX/texmf.local/fonts/map/*/updmap, /usr/local/texlive/2007/texmf- 
> var/fonts/map/*/updmap) while the "personal" updmap writes the MAP  
> files into the personal area at ~/Library/texmf/fonts/map/*/updmap.  
> Since both TEXMFSYSVAR and TEXMFSYSCONFIG are set to contain also  
> $HOMETEXMF, both updmap and updmap-sys read the MAP file fragments  
> form the system's area and from the user's private area. So it  
> makes a difference whether updmap-sys is invoked with a simple sudo  
> (then the proper user's HOMETEXMF area is searched) or with 'sudo - 
> H' 'sudo -H -u root' (then the root user's quite empty HOMETEXMF  
> area is searched).
>> Accordingly I think your suggestion would simply not work, or give  
>> unpredictable results. In order to allow user-specific setups, and  
>> restore updmap its default behaviour on teTeX 3 and TexLive, you  
>> would have to install the gwTeX i-Package in i-Installer in Expert  
>> mode: the choice of whether or not to allow user-specific setups  
>> (default choice: no) is the last one at the end of the Configure  
>> stage.
> Bruno, it works perfectly for me (and I think a few others, too)!  
> Nothing else is needed. And it keeps the system clean, not adding  
> to it false information about fonts only available for one person.  
> No-one gets confused about a font that is reported as existing but  
> cannot be used ...
> What I had to do is to configure the behaviour of the TeX  
> installation twice in terms of default paper size, downloading or  
> not downloading fonts, using the Karl Berry or another font naming  
> scheme, using the original fonts or the urw++ substitutes, and  
> using the same MAP file fragments from the system's area. Because  
> updmap is so slow it takes an hour or longer to fulfil the batch job.
> Upon request I can make it clearer and write down the start of such  
> a batch job ...

Dear all,

thanks for your replies to my earlier query.  Am I right in assuming  
that the upshot of the discussion was that I should simply use:

	updmap  --enable Map MinionPro.map

?  (I've tried this, and it produces no .map files in my private  
hierarchy (~/Library/texmf); should it?)

At any rate, I'm still unable to get MinionPro working.  Here is some  
relevant information:

1. Apparently I have an existing /usr/local/teTeX hierarchy on the  
machine, presumably from an earlier installation.   I don't think the  
TeX distribution I'm using (the latest one, gwTeX based on TeXLive  
2007) looks at it; but I figured I'd mention it just to be safe.

2. I actually have two machines.  On one, I got MinionPro to work, on  
the other I've failed. And the file /usr/local/gwTeX/texmf.local/ 
web2c/updmap.cfg (which is being used by updmap on each machine)  
contains  `Map MinionPro.map` on the machine in which things are NOT  
working; on the machine where the MinionPro package IS working, /usr/ 
local/gwTeX/texmf.local/web2c/updmap.cfg does NOT contain this  
command.   Which seems strange.

3. I installed MinionPro on the working computer a few months ago,  
before the most recent update of the MinionPro package.  (Perhaps  
that version was 2.0?  - the current version, and the one I've tried  
to install on the nonworking computer, is 2.1.)

4. The copy of MinionPro.map on the nonworking computer mentions some  
different files from those mentioned by MinionPro.map on the working  
computer.  (Presumably due to the update of the MinionPro package.)   
On the nonworking computer, I have .pfb fonts corresponding to some  
of the lines in MinionPro.map (e.g., MinionPro-Regular.pfb) but not  
all (e.g., MinionPro-SemiboldCapt.pfb).

5. Just to remind you; the output of the console when I try to  
typeset a document ends thus:   	

kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 0+545/600 --dpi  
545 MinionPro-It-Base-aa
mktexpk: don't know how to create bitmap font for MinionPro-It-Base-aa.
kpathsea: Appending font creation commands to missfont.log.

Warning: /usr/local/teTeX/bin/i386-apple-darwin-current/pdflatex  
(file MinionPr
o-It-Base-aa): Font MinionPro-It-Base-aa at 545 not found
0pk>kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 0+545/600 -- 
dpi 545 MinionPro-Regular-Base-aa
mktexpk: don't know how to create bitmap font for MinionPro-Regular- 

Warning: /usr/local/teTeX/bin/i386-apple-darwin-current/pdflatex  
(file MinionPr
o-Regular-Base-aa): Font MinionPro-Regular-Base-aa at 545 not found
Output written on Untitled.pdf (1 page, 2568 bytes).
Transcript written on Untitled.log.


Ted Sider

------------------------- Helpful Info -------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/
List Reminders & Etiquette: http://www.esm.psu.edu/mac-tex/list/

More information about the MacOSX-TeX mailing list