[OS X TeX] \includegraphics question

brian at pongonova.net brian at pongonova.net
Thu Nov 29 18:57:00 EST 2007

On Thu, Nov 29, 2007 at 09:14:09PM +0100, Bruno Voisin wrote:
> For example, in your last message you say you're using latex-suite  
> under vim. This is an essential element in your problem, I think.  
> Personally I've never used vi(m), and I've no idea what latex-suite  
> means. But most people following this thread have probably assumed  
> you're operating LaTeX through its front-end TeXShop, like most OS X  
> TeX users do.

Bruno, thanks for pointing this out -- I didn't think that running
under TexShop would have been an assumption I would have to address (I
thought TexShop was distinctly separate from MacTeX).

But I digress:  Your comment led me to digging deeper into the
logfile, and what I was missing was that the log was being overwritten
(as mentioned by another poster) because pdfeTeX is being run *twice*:
Once to generate a .dvi (which, in turn, is displayed by gs) and once
to generate a .pdf.  The second run overwrites the logfile, so it
wasn't apparent what was going on.

So essentially, what I have is my EPS files being used to generate a
.dvi file (with no intermediate conversion to PDF), and my PDF files
being used to generate a .pdf file.

While it would be nice to have the EPS files converted to PDF, I
suppose I'll just have to live with this.

BTW, epstopdf is generting the following error:

    Package epstopdf Warning: Graphics driver file `pdftex.def' not loaded

Would this be a possible reason why EPS files aren't being converted?


More information about the MacOSX-TeX mailing list