[OS X TeX] Re: ~/Library/texmf: solved

Josep M. Font jmfont at inicia.es
Thu Sep 6 10:04:02 EDT 2007

El 06/09/2007, a las 13:10, Peter Dyballa escribió:

> What is, on the command-line,
> 	env | grep TEX
> returning?


> And what
> 	kpsewhich texmf.cnf


> Can you also invoke this?
> 	find ~ -type d -name texmf


All done with Copy&Paste ;-).

El 06/09/2007, a las 14:01, Bruno Voisin escribió:


> then the problem must lie elsewhere.
> Possibility 1: When invoking latex, say, a LaTeX binary from some  
> other distribution is used (Fink, MacPorts, ...). Given you invoke  
> LaTeX through TeXShop, I see this as rather unlikely, but who knows.

I only installed gwtex and, in january, moved to texlive.

> Try, in Terminal,
> 	which latex
> You should get
> 	/usr/texbin/latex

Yes, that's what I get.

> Possibility 2: Something isn't as it should in TeXShop's prefs.  
> What do the 6 boxes in the Engine prefs contain?

pdftex --shell-escape
pdflatex --shell-escape
simpdftex tex --maxpfb
simpdftex latex --maxpfb

> Also, are you using specific engine files that you have written  
> yourself, in ~/Library/TexShop/Engines/ say?

No, I don't even know how to write one...

> Possibility 3: Some files in the hidden directory ~/.texlive2007/  
> are taking precedence over those in ~/Library/texmf/.

I don't have such directory (checked...$ ls -la in Terminal).

> Possibility 4: Do you, by any chance, have a hidden file ~/.MacOSX/ 
> environment.plist?

No (same as above).

> This file is very convenient when you want to customize your  
> environment and you are a programmer who knows exactly what he/ 
> she's doing, but for normal people just following someone else's  
> instructions it has been creating a number of problems in the past.
> Some tests to try:
> - Reduce your problem to a test file that people here could try,  
> and provide the corresponding console (or .log) output telling what  
> the problem is.
> - Identify one file that TeXShop complains it's not finding in the  
> console output, and which you know is indeed present in ~/Library/ 
> texmf/, and report the output of kpsewhich for that file. Namely,  
> if TeXShop complains it's not finding myfile.sty say, then report  
> the output of
> 	kpsewhich myfile.sty

kpsewhich correctly finds all files which, *up to now*, TeX refused  
to find. The mesage in the console was, for instance, "! LaTeX Error:  
File `sl.cls' not found ... Type X to quit or... etc)".

I say *up to now* because the problem seems to have silently solved  
itself! I can't understand how. Maybe thanks to the more extensive  
testing you advised. I don't know what happened. But the fact is that  
previously it did not find several of different files, not just one  
of them, in the private texmf tree, and now it finds them all!

> Hope this helps,

It did, indeed, although we dont' know exactly how!

Many thanks for your efforts in trying to understand the situation,  
and apologies for the typo!



------------------------- Helpful Info -------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/
List Reminders & Etiquette: http://www.esm.psu.edu/mac-tex/list/

More information about the MacOSX-TeX mailing list