[OS X TeX] Follow up on Two problems with Lucida Bright fonts on Mac Tex

Gordon Sick sick at ucalgary.ca
Mon Sep 24 14:11:34 EDT 2007

I just want to follow up on an earlier query that I posted. Bruno  
Voisin and Peter Dyballa gave helpful advice, but I was still a bit  
stuck on Lucida. In fact, I had messed things up so badly that it ran  
on none of my Latex distributions. So, I bought the TUG Lucida (I  
already owned the Y&Y Lucida), hoping that would help. I worked on  
the installation and finally realized that I had to find the solution  
by looking at the appropriate updmap.cfg files. When you run updmap- 
sys, an early output line gives you the path to the updmap.cfg file  
that is using. You have to go there to fix the problems.

My solution is outlined below. I found a small bug in gwTeX along the  

Running gwTex-2003-2005 as the Tex distribution, I attempted to  
enable my Lucida Bright fonts. I reported an earlier problem that it  
didn't work. Checking further, gwTex-2003-2005 seems to have the  
wrong name for lucidabr.map in the config file at

# Y&Y's Lucida Bright and  Lucida New Math supporting "Berry"-style
# tfm names (commercial fonts):
Map lucidabr.ma
Map lumath.map

# Y&Y's Lucida Bright and  Lucida New Math supporting "Y&Y"-style
# tfm names (commercial fonts):
#! Map lucidabr-o.map
#! Map lumath-o.map

The error is in Map lucidabr.ma, which should read Map lucidabr.map
Somebody should fix this error in the archives.

BTW, is the comment above incorrect inasmuch as lucidabr-o is Berry  
style and lucidabr.map is Y&Y style? Or do I have it backwards?

Running the gwTeX distribution, I tried to enable lucidabr.map with
sudo updmap-sys --enable Map lucida.map
It responded
updmap: configuration (updmap.cfg) unchanged. Map files will not be  

Bruno Voisin has kindly pointed out that updmap-sys thinks it has  
done the job already, so one has to first disable lucida with
sudo updmap-sys --disable lucida.map

But, then I get the message
!!! ERROR! The map file `lucidabr-o.map' has not been found at all.
which is surprising, because I thought I was trying to enable lucida,  
not lucidabr-o. So I checked the config file at the top of the updmap- 
sys at

It contains the lines
#! Map lucida.map
Map lucidabr-o.map
Map lumath-o.map

Since I was trying to disable lucida.map, this seems OK, but it  
shouldn't then enable lucidabr-o and lumath-o, so I commented them  
out and re-ran to avoid the error:
sudo updmap-sys --disable lucida.map
sudo updmap-sys --enable Map lucida.map

The bottom line is that I now am able to typeset Lucida Bright  
properly (small caps and everything) on all 3 LateX distributions:  
gwTeX (teTeX), gwTeX-2003-2005 and TeXLive-2007.

One final comment about preambles. The lucida-sample.tex file that  
comes from CTAN has a different preamble than the one I used to use  
(as recommended by earlier posters):

% we have to change the font encoding for Lucida.
\usepackage{textcomp} % to get the right copyright, etc.

% use Lucida fonts for both text and math.
\usepackage[altbullet]{lucidabr}     % get larger bullet
\DeclareEncodingSubset{TS1}{hlh}{1}  % including \oldstylenums

I can see that I might want to kill the oldstylenums for technical  
writing, but the big change is the T1 font encoding, rather than LY1.  
The reason why  I didn't get small caps may have been that LY1 has  
poor support for it (I read that somewhere).

--cheers, Gordon Sick

------------------------- Helpful Info -------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/
List Reminders & Etiquette: http://www.esm.psu.edu/mac-tex/list/

More information about the MacOSX-TeX mailing list