[OS X TeX] Tags, BibTeX, and font question for TeXShop

Herbert Schulz herbs at wideopenwest.com
Tue Jul 1 10:59:35 EDT 2008

On Jul 1, 2008, at 7:49 AM, R Martinez wrote:

> All,
> I am using LaTeX with TeXShop Version 2.14 on a MacBook Pro and the  
> 2007 MacTeX distribution. I will appreciate help with the following  
> three issues.
> 1. TeXShop has a Tags menu that displays all the sections,  
> subsections, etc. But it does not display the equation tags. Can the  
> equation tags be displayed? I would like to see a list of the  
> equation tags, not necessarily under the tags menu.


Not automatic, but you can add your own tags (that appear in the tags  
drop down) by having a line


which can be generated using Source->New Tag (Cmd-2) and adding the  
tagname. For equations you could build a macro the does this, places  
the in place to write the tag name and also generates equation  
environment. There are macros supplied with my Command Completion code  
that will even allow you to add place holders (called Tags too,  
Sigh...) in the macros and jump to them: get it as  
CommandCompletion.zip from http://homepage.mac.com/herbs2>.

> 2. I'm having a problem with BibTex, which was working fine with  
> TeXShop until I added three new references to the BibTeX file. I use  
> BibDesk to create and update my .bib file. The typeset preview of  
> my .tex document displays everything correctly, including the old  
> references, but it cannot find the three new references. TeXShop  
> does not add them to the typeset bibliography (which does display  
> the original 9 references) and the citations of the three new  
> references in the text display as [?]. I have verified that the  
> updated .bib file includes the three new references. The .bibl file  
> created by TeXShop contains only the 9 original references.

I assume you the .bbl file. Do you get a display if you as BibDesk for  
a Preview of the ones you added? Try removing all the auxiliary files  
(.aux, .bbl, etc.) and recompiling. Are you running bibtex in between  
the runs of latex (I see you're using epsfig so you shouldn't be  
running pdflatex)?

> 3. I tried to use the mathbb font shown in TeXShop's LaTeX panel,  
> but I get an error when I try to typeset. Here's an example:
> $\mathbb{a}$
> The console reads:
> !Undefined control sequence
> <recently read> \mathbb
> I.440 $\mathbb
> 		{a}$
> ?

Sorry, I can't be of any help here.

> Incidentally, I tried to select and copy the console's error message  
> shown above, but the console does not let me select the text. Why is  
> that?

Since TeXShop is expecting user input at the error the input area is  
selected. Click on the Console Window to activate it and I believe  
you'll be able to copy. If not, Abort and then do that.

> Here's the preamble for my document.
> \documentclass[12pt]{article}
> \usepackage{lmodern}    \usepackage[T1]{fontenc}
> \usepackage{amsmath,epsfig,latexsym,bm}
> \usepackage{exscale,relsize}
> \usepackage{tocbibind}
> Can anyone help?
> Thanks in advance.
> Raul Martinez

This has nothing to do with anything above, but I'd add  
\usepackage{textcomp}, to get extra symbols defined, just after the  
fontenc line.

Good Luck,

Herb Schulz
(herbs at wideopenwest.com)

More information about the MacOSX-TeX mailing list