[OS X TeX] latexit issues

Owen Densmore owen at backspaces.net
Sun Jul 20 11:08:53 EDT 2008

Hi Peter.  Thanks for the help.

It seems to me that LaTeXiT should not be executing bash, but the initial
bourne shell, sh.

I realize many systems, including Mac, use bash for sh, but in that case,
the shell is called with this invocation flag:
  --norc Do  not  read  and  execute  the	personal  initialization  file
    ~/.bashrc  if  the  shell  is interactive.  This option is on by
    default if the shell is invoked as sh.

Also, I'm not sure avoiding my interactive startup would make a difference
because of these experiments:
1 - First, I created a new account on my Mac and tried LaTeXiT there and it
worked fine.  This shows that my TeX install, which is global, works as it
2 - In my account, I move all the .bashxx files off to the side so that the
system should not be reading them.  When I do this, I do not get an the same
error as above, but I do a tiny error message in the display pane.  It does
not say the usual about see the Log file.  I even tried this with a reboot
just to make sure the initial login didn't also use the .bashxx files.
3 - With the .bashxx files in place, I get the error we've been discussing.

So, the problem must be in my environment somewhere, but doesn't seem to be
in the .bashxx files.


I've "solved" the problem this much: I just use TextMate's LaTeX mode and
PDF previewer.  That works quite well.  So I'm at least on the air. 

   -- Owen

View this message in context: http://n2.nabble.com/latexit-issues-tp572712p574017.html
Sent from the MacOSX-TeX mailing list archive at Nabble.com.

More information about the MacOSX-TeX mailing list