[OS X TeX] Problem with psnup

Luis Sequeira lfsequeira at gmail.com
Thu Jun 12 03:56:42 EDT 2008

> Hello list,
> I have a problem with psnup which I would always ascribe
> to my own lack of expertise, were it not for the fact that
> it works on a linux machine.
> I have a ps file (produced with latex/dvips from MacTeX-2007).
> Then I do
>    psnup -2 document.ps doctup.ps
> in order to put two pages on each A4 sheet.
> The result of psnup is unexpected: it looks like
> something involving the letter paper size: if I give
> the -d option to have a thin frame around the
> pages, I can see that there is spurious extra
> space along the long side of the A4 sheet containing
> the two pages (i.e. along the bottoms of the two pages),
> whereas the right-hand page on the sheet it truncated
> on the right as if the sheet was not long enough.
> I have tried with the -pa4 switch, but it makes no
> difference.
> The psnup command works as expected on a linux machine,
> and therefore I conclude that there is something wrong
> with my tex installation.
> I have verified that it is not a problem with
> Preview or the underlying pstopdf: the ps file produced
> by psnup on the linux machine is correctly distilled by
> Preview.
> (The linux machine is some sort of ubuntu, it is not
> mine, and I know nothing about linux.)
> My own machine is an iMac with 10.5.2.
> The MacTeX is TeX-live-2007.  I have no other tex
> installation or alternative psutils.
> psnup says "psnup release 1 patchlevel 17"
> (that's exactly the same version reported on the
> linux machine).
> [My settings are for A4, as far as I know: in the System
> Preferences, Print and Fax I have A4 as preferred paper size.
> The MacTeX installer does not ask, but there is a mention that
> if problems occur, to issue these two commands (which I have
> tried):
>    sudo texconfig-sys paper a4
>    sudo texconfig-sys dvips paper a4
> Both these commands gave the message:
> texconfig: updated configuration saved as file `/usr/local/texlive/ 
> 2007/texmf-config/dvips/config/config.ps'
> Is there a way to query the value of the paper-size setting?
> In any case, it seems this is unrelated since the -pa4 switch
> has no effect, and I have also noticed that in the ps file
> produced by psnup there is DocumentPaperSizes: a4 in the
> preamble.]
> Any advice is appreciated.  It would also be interesting
> to hear if anybody else experience this problem.
> I am ready to provide more details if needed, and to invest
> some time in debugging, if given proper instructions.
> Thanks in advance.
> Cheers,
> Joachim.

I got exactly the same result as you did. There does seem to be  
something wrong.

I tried to convert a ps file to pdf (just double-clicking on it to  
have preview convert it and then save as...) and then use pdfpages to  
do the nup. It worked flawlessly.
It is not a one command line thing, of course, but it does work - and  
involves TeX :-)
Just make a LaTeX document loading the pdfpages package and containing  
the following (after \begin{document}, of course):


(the frame option draws a frame around each logical page, much as the - 
d option  of psnup)

Luis Sequeira

More information about the MacOSX-TeX mailing list