[OS X TeX] Re: Leopard, MacTeX2007 and gv

Rob Rye rye at usc.edu
Fri Jun 27 19:23:31 EDT 2008

Hi Eric,

No need to say goodbye to gv:

GNU is maintaining gv and their source appears to install fine on my  

The following procedure worked fine for me on a PPC machine running  
Leopard 10.5.3

1. Install Xaw3d using i-Installer
2. Download source for gv from gnu at http://www.gnu.org/software/gv/
3. Open a terminal window and go to your downloads folder
4. tar -xvzf gv-3.6.4.tar.gz
5. cd gv-3.6.4
6. ./configure
7. make
8. sudo make install

gv should now be available. Just call it from /usr/local/bin/gv  
(unless you told configure to put it somewhere else)

If you try steps 2-8 without installing Xaw3d (or re-installing it as  
the case may be) gv will not configure properly and make is not  
available. However, Gerben's version of Xaw3d is precisely what I  
configured gv against...

I have had no troubles with my installation of gv after following this  
procedure, though I grant I don't use it a lot.



> Well, goodbye gv!
> Thanks to all
> Eric
> Le 27 juin 08 à 13:27, Bruno Voisin a écrit :
>> Le 27 juin 08 à 12:46, Eric van der Oord a écrit :
>>> G. Wierda's instalI  -- I've just tried -- does not seem adapted to
>>> Leopard.
>> You're right, i-Installer fails to install gv on Leopard. Status
>> lines yield:
>> http://www.ntg.nl/macosx-tex/i-packages/gv.ii2/gv.l.bz2 download
>> (255 Bytes) has started (255 Bytes)
>> http://www.ntg.nl/macosx-tex/i-packages/gv.ii2/gv.l.bz2 download
>> (255 Bytes) has completed (255 Bytes at 2.0 GB per second)
>> Checking (required) dependency set 0 (all should be available).
>> Reason: X11R6 + Xaw3d needs to be installed on your system
>> ## Required  file /usr/X11R6/lib/libX11.dylib is available. Good.
>> ## Required  file /usr/X11R6/lib/libXaw3d.dylib is available. Good.
>> Dependency requirements fulfilled.
>> Starting trueinstall tasks
>> Prepare stage completed
>> Unarchive stage failed
>> And corresponding error message is:
>> /usr/bin/tar: ./usr/X11R6/lib/X11/app-defaults: Cannot open: File
>> exists
>> I've no idea what that means. Not using gv myself, I can't help.
>> Remember moreover the warning in the i-package Readme:
>> • NOTE: gv is old and as far as I know not maintained. I had to hack
>> around in the sources to get it to work and I will not be able to
>> provide decent support.
>> And that was even before Gerben announced end of support for i-
>> Installer.
>> Bruno Voisin
>> -------------------------- Helpful Info --------------------------
>> TeX FAQ: http://www.tex.ac.uk/faq
>> List Reminders and Etiquette: http://www.esm.psu.edu/mac-tex/list/
>> List Info: http://email.esm.psu.edu/mailman/listinfo/macosx-tex
>> List Archive: http://tug.org/pipermail/macostex-archives/
>> Mac-TeX Website: http://www.esm.psu.edu/mac-tex/

More information about the MacOSX-TeX mailing list