[OS X TeX] Questions about font maps

Francesco Costanzo costanzo at engr.psu.edu
Tue May 13 17:26:31 EDT 2008

Hi there,

I have some questions about enabling and updating font maps.  These  
questions are motivated by a fresh texlive2007 installation that I did  

Here is what I did:
[1] I installed TeXLive 2007 on a MacBook Pro 2.4 GHz running  MacOS X  
10.5.2.  No prior installation of TeX or LaTeX existed on the  
machine.  The distribution I installed was "TeXLive-2007-Dev" whose  
link is found on the following page: <http://tug.org/mactex/ 
morepackages>.  In addition, I installed the "LeopardTeXFix"  
downloaded from <http://www.uoregon.edu/~koch/LeopardTeXFix.pkg.zip>.

[2] I then copied on this machine the "texmf" folder (along with its  
contents) from another computer.  The "texmf" folder in question was  
placed in "~/Library/" and, among other things, it contains font  
installations for mtpro2 and lucida fonts.

[3] I then enabled the mtpro2.map and lucida.map using the command  
"sudo updmap-sys --enable Map mtpro2.map" (similarly for the lucida)  
and run a final "sudo updmap-sys" (I also disabled the belleek.map)

[4] At the end of this process, I run some tests.  Namely, I typeset  
two test documents with mtpro2 and lucida fonts using pdflatex.   
However, the typesetting process was not successful in that the fonts  
where not being found and they were substituted with "nonsense".

[5] Since the machine I was setting up was not mine, I started  
comparing the new installation with the one I have on my machine (also  
a MacBook Pro running MacOS X 10.5.2, albeit a bit older).   
Specifically, I compared the updmap.cfg files that can be found under / 
usr/local/texlive/2007/ on the two machines and in both cases the font  
maps mentioned earlier were included in identical ways.  I did a  
similar check on the pdftex.map files and, again, things seemed OK.

[6] Then I compared the log files of two identical documents typeset  
in identical ways, one done with the new installation and the other  
done with the installation I have on my computer (where things seems  
to work as they should).  The comparison in question revealed the  

*from the log on my own computer*
the pdftex.map file used was in

*from the log on the new computer*
the pdftex.map file used was in

[7] At this point I discovered that, while my machine does have a  
".texlive2007/texmf-var/fonts/" folder, I do not have a "/Users/ 
theusername/.texlive2007/texmf-var/fonts/map/pdftex/updmap/" folder  
and therefore I do not have the pdftex.map file contained therein.  In  
addition, the "/Users/theusername/.texlive2007/texmf-var/fonts/map/ 
pdftex/updmap/pdftex.map" file on the new machine had not been  
updated, contrary to what had happened for the same file residing  
under /usr/local/texlive/2007/ on the same machine.

[8] At this point, I guessed that what needed to be done on the new  
machine what to repeat the step described in [3], except that this  
time I used "updmap" instead of "updmap-sys".  The guess seemed to  
have worked.

With the above in mind, I must confess that I am extremely confused:
   (i) What is the correct set up that one should have? That is, I am  
going to run into troubles in the future given that my own  
"~.texlive2007" folder does not look like what is produced by  
"TeXLive-2007-Dev" distribution I used yesterday?
  (ii) Why did the guess in [8] worked?
(iii) Why running "updmap-sys" did not update the maps under  

Let me know if anyone has any insight on the issues I described.

Best Regards,
Francesco Costanzo
Associate Professor

Address: Engineering Science and Mechanics Department
          The Pennsylvania State University
          212 Earth and Engineering Sciences Building
          University Park, PA 16802-1401
Phone:   (814) 863-2030
Fax:     (814) 865-9974
mailto:costanzo at engr.psu.edu

More information about the MacOSX-TeX mailing list