[OS X TeX] Installing Monotype Times New Roman

Bruno Voisin bvoisin at mac.com
Sun May 18 04:33:50 EDT 2008

Le 18 mai 08 à 09:32, Adam Fenn a écrit :

> I followed the instructions for a user-specific installation and  
> then ran in Terminal;
> updmap --enable Map mnt.map
> updmap: using transcript file `/Users/administrator/.texlive2007/ 
> texmf-var/web2c/updmap.log'
> updmap: initial config file is `/usr/local/texlive/2007/texmf-config/ 
> web2c/updmap.cfg'
> updmap: configuration (updmap.cfg) unchanged. Map files will not be  
> recreated.
> I deleted the .texlive2007 directory and tried again with the same  
> result.

Try to run in sequence:

updmap --disable mnt.map
updmap --enable Map mnt.map

Problem seems to be: you tried beforehand to enable mnt.map and it  
didn't work (updmap failed to find mnt.map and hence couldn't add its  
content inside psfonts.map and friends), but updmap.cfg has been  
updated then (reference to mnt.map has been added to it); accordingly,  
when you try to enable again mnt.map, updmap remarks that updmap.cfg  
contains reference to mnt.map already, considers work has already been  
done, and refuses to proceed further.

Just to clarify: when running "updmap --enable Map somefile.map":

- updmap.cfg is added the line Map filename.map

- updmap.cfg is read anew, if updated content differs from previous  
content updmap proceeds further and if not aborts

- all the .map files referenced in updmap.cfg are looked for, read and  
their content added inside psfonts.map, pdftex.map and dvipdfm.map  
with the appropriate syntax

> I ran locate updmap.cfg in Terminal
> /usr/local/teTeX/man/man5/updmap.cfg.5
> /usr/local/teTeX/share/texmf.local/web2c/updmap.cfg
> /usr/local/teTeX/share/texmf.tetex/web2c/updmap.cfg
> If I try to open any of these  Terminal claims they don't exist.

Those files pertains to an older obsolete deprecated install of teTeX.  
Most likely, you haven't updated your locate database in a long time  
and these files don't exist any longer. If they do, bad news, because  
when running TeX some files are read from a TeXLive install and others  
from a teTeX install, forming an inconsistent mix.

First step to take: open System Preferences > TeX Distribution and  
make sure TeXLive-2007 is selected. Second step: navigate manually to / 
usr/local (for example Cmd-Shift-G in Finder) and check whether  
there's a teTeX directory there; if so, delete it (after saving all  
parts you might have added yourself willingly).

udmap.cfg that should be used is /usr/local/texlive/2007/texmf-config/ 

> I also have a pdftex.cfg file at
> /Users/administrator/Library/texmf/fonts/pdftex/pdftex.cfg
> Do I need to delete that?

Surely. pdfTeX has stopped using pdftex.cfg several years ago, this  
config file is now replaced by


IIRC pdftex.cfg ceased to exist when teTeX changed from version 2 to  
3. You seem to use a setup combining scattered pieces from teTeX 2  
with TeXLive 2007, which is prone to problems. I'd advise erasing


completely, after saving from


all the pieces that you may have added yourself (like all the Minion- 
Pro related files), then reinstalling from scractch.

That said, I'm not familiar with user-specific installations (not  
using them).

Bruno Voisin (offline for the rest of the day probably)

More information about the MacOSX-TeX mailing list