[OS X TeX] XeLaTeX problems with includegraphics

Peter Dyballa Peter_Dyballa at Web.DE
Thu Sep 4 05:30:15 EDT 2008

Am 04.09.2008 um 09:14 schrieb Peder Axensten:

> I've created the pdf in three different ways now: Illustrator,  
> FreeHand, and GhostScript – in all cases I still get the message of  
> "missing endobj". I don't think it's the graphic file... Also,  
> pdflatex compiles the same tex file without a problem.

Adobe Reader 6.0.2 tells: Invalid color: colored pattern specified  
with uncolored pattern colorspace.

Using convert from ImageMagick 6.4.1 to convert your PDF file to JPEG  
I get:

    **** Warning: stream operator not terminated by valid EOL.

    **** This file had errors that were repaired or ignored.
    **** Please notify the author of the software that produced this
    **** file that it does not conform to Adobe's published PDF
    **** specification.

Looking into the PDF file I see that the bitmap comes inside a Flate  
encoded stream, which ends with the command endstream. I don't think  
this is correct, at least I've never seen a PDF file where the finish  
statement was part of the data, i.e., it was always on a separate  
line. Editing the PDF file in GNU Emacs by moving the endstream  
command to a single line does not create a valid PDF file.

It worked to convert (save as) slu.pdf in Preview a PNG file. Convert  
could convert it into another PDF file which XeTeX could include and  
create a PDF output file.

It even worked to save slu.pdf as PDF with a new name from Preview –  
although it's now "upgraded" to PDF 1.3 ... but it works for XeTeX!



When confronted with actual numbers, a mathematician is at a loss.
				– Steffen Hokland

More information about the MacOSX-TeX mailing list