[OS X TeX] Curious xelatex font problem

Bruno Voisin bvoisin at me.com
Sat Sep 6 18:04:12 EDT 2008

Le 6 sept. 08 à 23:30, Reinaert Albrecht a écrit :

> Well, this turns out to be a lot weirder than I even could imagine.  
> The
> problem seems to be a weird combination of iTerm and macosx's  
> screen. If I use
> macports screen version i'm immediately out of trouble. But somehow  
> that can't
> be derived from the environment variables... "which xelatex" gives  
> me the
> exact same result /usr/texbin//xelatex. kpsewhich doesn't seem to  
> work, it
> exits with 1 as exit code.
> The problem seems to be macosx's screen version. I've included the  
> env output
> in both screens. The only noticable difference seems to be in the  
> termcap
> variables. Can that be the problem?
> Obviously my problem is solved but I'm still curious as to why.  
> Anybody ideas?

Sorry, I can't help more here. You obviously have a solid Unix  
background, I don't: you're using terms such as macosx screen version,  
macports screen version, termcap, iTerm, and one of our attachment is  
called gnuscreen, but these terms mean absolutely nothing to me.

In any case, the fact that kpsewhich doesn't work means your TeX setup  
is seriously damaged.

Bruno Voisin

More information about the MacOSX-TeX mailing list