[OS X TeX] Curious xelatex font problem

Jonathan Kew jonathan at jfkew.plus.com
Sat Sep 6 18:23:54 EDT 2008

On 6 Sep 2008, at 10:30 PM, Reinaert Albrecht wrote:

> Well, this turns out to be a lot weirder than I even could imagine.  
> The
> problem seems to be a weird combination of iTerm and macosx's  
> screen. If I use
> macports screen version i'm immediately out of trouble. But somehow  
> that can't
> be derived from the environment variables... "which xelatex" gives  
> me the
> exact same result /usr/texbin//xelatex. kpsewhich doesn't seem to  
> work, it
> exits with 1 as exit code.

No, that's just because the command that was suggested (kpsewhich  
xelatex) won't find anything -- kpsewhich doesn't look for executables  
(like "which"), but for input files, etc.

> The problem seems to be macosx's screen version. I've included the  
> env output
> in both screens. The only noticable difference seems to be in the  
> termcap
> variables. Can that be the problem?

It seems unlikely. Seeing the full transcript of a failed run might  
help us to figure out what is going wrong.

> Obviously my problem is solved but I'm still curious as to why.  
> Anybody ideas?

My guess is still that you have some old TeX-related binaries  
somewhere, and a path difference in the environments is affecting what  
is found. What does "locate xdvipdfmx" show?


More information about the MacOSX-TeX mailing list