[OS X TeX] TeX Live Utility/tlmr problem

Herbert Schulz herbs at wideopenwest.com
Mon Nov 2 10:01:52 EST 2009

On Nov 1, 2009, at 9:40 AM, Adam R. Maxwell wrote:

> On Oct 31, 2009, at 11:39 PM, Alessandro Languasco wrote:
>> sh-3.2# tlmgr update --all
>> tlmgr: package repository http://ftp.cstug.cz/pub/tex/tlnet/
>> /usr/local/texlive/2009/tlpkg/installer/xz/xzdec.universal-darwin:  
>> (stdin): File format not recognized
>> First directive needs to be 'name', not <!DOCTYPE html PUBLIC "-// 
>> W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd 
>> "> at /usr/local/texlive/2009/tlpkg/TeXLive/TLPOBJ.pm line 123,  
>> <RETFH> line 1.
>> Trying again tlmgr update --self gives now the same error.
>> So it seems that the tlmgr auto-update on the mac (at least on  
>> mine...) installs some corrupted file.
>> I tried also to reinstall the TexLive Manager in TLU with no success.
> I just updated mine here:
> $ tlmgr --version
> tlmgr revision 15761 (2009-10-11 10:00:42 +0200)
> tlmgr using installation: /usr/local/texlive/2009
> TeX Live (http://tug.org/texlive) version 2009
> /usr/texbin/tlmgr --machine-readable --repository http://ftp.cstug.cz/pub/tex/tlnet/ 
>  update --list
> runs with no problems (this is what TLU uses).  I've no idea what's  
> going on, so please post to tex-live at tug.org and see if the tlmgr  
> developers can figure this out.


Given that there was a typo in TLUtils.pm how come you and I seemed to  
have no problem with TLU when updating the last few days? I confirmed  
the typo on my system and then corrected it but things were working  
before that too. By the way, did TLUtils.pm get updated in today's  
updates? The date (don't remember the time I did the fix) is still  
yesterday (11/1)?

Good Luck,

Herb Schulz
(herbs at wideopenwest dot com)

More information about the MacOSX-TeX mailing list