[OS X TeX] Snow Leopard Font Problems

Stephen Anderson sra at yale.edu
Mon Nov 2 17:27:59 EST 2009

The problem I reported before has been identified, and cleared up in  
one sense, but I'm still not home.

On Fri, 23 Oct 2009, Herbert Schulz wrote:

> Oh my goodness... I see that you're still using gwTeX. That's at least
> 4 years old and quickly going out of date.

I must say that I was not aided a great deal by the fact that

On Fri, 23 Oct 2009, David Watson wrote:

> I'm glad you caught that Herb.
> <snark>
> I seem to recall someone starting this thread with the claim that they
> were using TeXLive 2008.
> </snark>
> Oh well... at least we have someone around here paying attention!

Whatever.  In any case, it puzzled me: I had certainly downloaded and  
installed TexLive-2008, and selected that in the Tex Distribution  
Utility panel in System Preferences.  But of course Herb was right:  
TeXShop WAS using old gwTeX.  I finally figured out that I had put the  
path to gwTeX in TeXShop, and that's what was happening.  Once I fixed  
that, the little sample file with a URL and some \texttt text ran fine.

But getting the right TeX version only moved the issue along a bit.   
My real problem comes from the fact that when writing letters on Yale  
letterhead, I want to use an internal Yale-designed font  
("YaleAdmin").  This has always worked fine for me before with XeTeX.   
It works fine now in Mac applications like MIcro$oft Word.  But when I  
invoke it in an XeTeX document, it aborts the whole process.  Here's a  

> %%% -*- Mode: LaTeX -*-
> %!TEX TS-program = xelatex
> \documentclass[11pt]{yale-letter}
> \usepackage{url}
> \usepackage{fontspec}
> \usepackage{xunicode}
> \usepackage{xltxtra}
> \defaultfontfeatures{Mapping=tex-text}
> \name{Prof. Stephen R. Anderson}
> \signature{Stephen R. Anderson \\Dorothy R. Diebold Professor of
>   Linguistics (Chair)}
> %
> % Phone number appears at bottom right of first page if present
> %
> \telephone{(203) 432--2456}
> %
> % Email (if present) OR fax number appears at bottom left
> %   of first page
> %
> \email{sra at yale.edu}
> %\fax{(203) 432--4087}
> \begin{document}
> \fontspec[ItalicFont={YaleAdmin-Italic},
> BoldFont={YaleAdmin-BoldRoman},
> BoldItalicFont={YaleAdmin-BoldItalic},
> SmallCapsFont={YaleAdmin-SmallCap}]
> {YaleAdmin}
> \begin{letter}{Professor Foo B. Bahz}
> \opening{Dear Professor Bahz:}
> Thank you for agreeing to assist me in fixing my font problem.   It
> would be most helpful if I could have your response by 15
> December, 2009, and an e-mail to me at \url{sra at yale.edu} would be  
> just
> fine.
> \closing{Sincerely yours,}
> \end{letter}
> \end{document}

And here's the output in TeXShop:

> This is XeTeXk, Version 3.1415926-2.2-0.999.6 (Web2C 7.5.7)
>  %&-line parsing enabled.
> entering extended mode
> (./FooLetter.tex
> LaTeX2e <2005/12/01>
> Babel <v3.8l> and hyphenation patterns for english, usenglishmax,  
> dumylang, noh
> yphenation, german-x-2008-06-18, ngerman-x-2008-06-18, ancientgreek,  
> ibycus, ar
> abic, basque, bulgarian, catalan, pinyin, coptic, croatian, czech,  
> danish, dutc
> h, esperanto, estonian, farsi, finnish, french, galician, german,  
> ngerman, mono
> greek, greek, hungarian, icelandic, indonesian, interlingua, irish,  
> italian, la
> tin, lithuanian, mongolian, mongolian2a, bokmal, nynorsk, polish,  
> portuguese, r
> omanian, russian, sanskrit, serbian, slovak, slovenian, spanish,  
> swedish, turki
> sh, ukenglish, ukrainian, uppersorbian, welsh, loaded.
> (/Users/sra/Library/texmf/tex/latex/local/yale-letter.cls
> Document Class: yale-letter 2004/11/07 v1.0 local variant of  
> Standard LaTeX doc
> ument class
> (/usr/local/texlive/2008/texmf-dist/tex/latex/base/size11.clo))
> (/Users/sra/Library/texmf/tex/latex/local/misc/url.sty)
> (/usr/local/texlive/2008/texmf-dist/tex/xelatex/fontspec/fontspec.sty
> (/usr/local/texlive/2008/texmf-dist/tex/generic/ifxetex/ifxetex.sty)
> (/usr/local/texlive/2008/texmf-dist/tex/latex/tools/calc.sty)
> (/usr/local/texlive/2008/texmf-dist/tex/latex/xkeyval/xkeyval.sty
> (/usr/local/texlive/2008/texmf-dist/tex/generic/xkeyval/xkeyval.tex
> (/usr/local/texlive/2008/texmf-dist/tex/generic/xkeyval/keyval.tex)))
> (/usr/local/texlive/2008/texmf-dist/tex/latex/base/fontenc.sty
> (/usr/local/texlive/2008/texmf-dist/tex/xelatex/euenc/eu1enc.def)
> (/usr/local/texlive/2008/texmf-dist/tex/xelatex/euenc/eu1lmr.fd))
> fontspec.cfg loaded.
> (/usr/local/texlive/2008/texmf-dist/tex/xelatex/fontspec/ 
> fontspec.cfg))
> (/usr/local/texlive/2008/texmf-dist/tex/xelatex/xunicode/xunicode.sty)
> (/usr/local/texlive/2008/texmf-dist/tex/xelatex/xltxtra/xltxtra.sty
> (/usr/local/texlive/2008/texmf-dist/tex/latex/graphics/graphicx.sty
> (/usr/local/texlive/2008/texmf-dist/tex/latex/graphics/graphics.sty
> (/usr/local/texlive/2008/texmf-dist/tex/latex/graphics/trig.sty)
> (/usr/local/texlive/2008/texmf/tex/latex/config/graphics.cfg)
> (/usr/local/texlive/2008/texmf-dist/tex/xelatex/xetex-def/xetex.def)))
> (/usr/local/texlive/2008/texmf-dist/tex/latex/etex-pkg/etex.sty)
> (/usr/local/texlive/2008/texmf-dist/tex/latex/base/fixltx2e.sty))
> No file FooLetter.aux.
> (/usr/local/texlive/2008/texmf-dist/tex/xelatex/euenc/eu1lmtt.fd) [1]
> (./FooLetter.aux)
> ** ERROR ** Invalid font: -1 (0)
> Output file removed.
>  )
> Error 256 (driver return code) generating output;
> file FooLetter.pdf may not be valid.
> Transcript written on FooLetter.log.

I can't determine from this what the invalid font is....

I've been at this with FontBook, and then Linotype Font Explorer  
(latest version).  I've replaced the font (identified at PostScript  
(Type 1)), scrubbed duplicates, cleaned the font cache and restarted,  
and nothing seems to work.  As I say, this font worked fine in Leopard  
(even though I was unknowingly still using gwTeX!), but no more.

I would be grateful for hints, less grateful for snarks... :-)

Thanks in Advance,


Steve Anderson

More information about the MacOSX-TeX mailing list